summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Buchar2023-11-01 17:07:34 +0100
committerJan Buchar2023-11-01 17:07:34 +0100
commit4a8bd832e12acefcbc00b60aff7036c922f68626 (patch)
tree3f23d3e3a649b25428dd49a2d117745b2309cc06
downloadaur-4a8bd832e12acefcbc00b60aff7036c922f68626.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD35
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a5cff88c293
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = flite-unpatched
+ pkgdesc = A lightweight speech synthesis engine (built without Arch linux patches)
+ pkgver = 2.2
+ pkgrel = 1
+ url = http://www.festvox.org/flite/
+ arch = x86_64
+ license = custom
+ makedepends = chrpath
+ depends = alsa-lib
+ source = https://github.com/festvox/flite/archive/v2.2/flite-2.2.tar.gz
+ sha256sums = ab1555fe5adc3f99f1d4a1a0eb1596d329fd6d74f1464a0097c81f53c0cf9e5c
+
+pkgname = flite-unpatched
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2beec4ecae26
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname=flite-unpatched
+_pkgname=flite
+pkgver=2.2
+pkgrel=1
+pkgdesc="A lightweight speech synthesis engine (built without Arch linux patches)"
+arch=(x86_64)
+url="http://www.festvox.org/flite/"
+license=(custom)
+depends=(alsa-lib)
+makedepends=(chrpath)
+source=(https://github.com/festvox/flite/archive/v$pkgver/$_pkgname-$pkgver.tar.gz)
+sha256sums=('ab1555fe5adc3f99f1d4a1a0eb1596d329fd6d74f1464a0097c81f53c0cf9e5c')
+
+prepare() {
+ cd $_pkgname-$pkgver
+ #sed '/^#VOXES.*$/d; s/+//g; s/cmu_indic_lex/&\nVOXES = cmu_us_kal16 cmu_us_slt/' config/android.lv >config/archlinux.lv
+ #sed -i '/$(INSTALL) -m 755 $(BINDIR)\/flite_time $(DESTDIR)$(INSTALLBINDIR)/d' main/Makefile
+}
+
+build() {
+ cd $_pkgname-$pkgver
+ ./configure --prefix=/usr --enable-shared
+ make
+ make get_voices
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -D -m644 COPYING "$pkgdir"/usr/share/licenses/$_pkgname/LICENSE
+
+# Fix rpath
+ chrpath -d "$pkgdir"/usr/bin/*
+}
+