summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Gatzweiler2015-06-09 15:22:54 +0200
committerThomas Gatzweiler2015-06-09 15:22:54 +0200
commit8f4c0aec7bab02ce7fc195e6152af6f3d06c792a (patch)
treec3f0181ef3061b31c6d01685333b6ed7cde912f5
downloadaur-8f4c0aec7bab02ce7fc195e6152af6f3d06c792a.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..937979972232
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = flmsg
+ pkgdesc = Forms management editor for Amateur Radio standard message formats
+ pkgver = 2.0.10
+ pkgrel = 1
+ url = http://www.w1hkj.com/flmsg-help/index.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = fldigi
+ source = http://w1hkj.com/downloads/flmsg/flmsg-2.0.10.tar.gz
+ md5sums = 9068f9e8f5dd70867a4e62e1722cf321
+
+pkgname = flmsg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d74c9dfcff00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Thomas Gatzweiler <thomas.gatzweiler@gmail.com>
+
+pkgname=flmsg
+pkgver=2.0.10
+pkgrel=1
+pkgdesc="Forms management editor for Amateur Radio standard message formats"
+arch=('i686' 'x86_64')
+url="http://www.w1hkj.com/flmsg-help/index.html"
+license=('GPL')
+depends=('fldigi')
+source=(http://w1hkj.com/downloads/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('9068f9e8f5dd70867a4e62e1722cf321')
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make -k check
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}