summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrien Prost-Boucle2017-02-07 20:46:15 +0100
committerAdrien Prost-Boucle2017-02-07 20:46:15 +0100
commit9b5fa0991b03bc0782363182dddeb42a5fc70d06 (patch)
tree1aff02e46ddfc3fbb9372e9e15e98b172a20a38d
parentca454b9001bca2b71e49cc388a103a87f5fb6736 (diff)
downloadaur-9b5fa0991b03bc0782363182dddeb42a5fc70d06.tar.gz
Update for version 4.1
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD14
3 files changed, 24 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f940653d53d..bcd064188232 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Tue Feb 7 19:30:33 UTC 2017
pkgbase = flopoco
pkgdesc = A generator of arithmetic cores (Floating-Point Cores, but not only) for FPGAs (but not only)
- pkgver = 2.5.0
+ pkgver = 4.1
pkgrel = 1
url = http://flopoco.gforge.inria.fr/
arch = any
@@ -10,10 +12,11 @@ pkgbase = flopoco
depends = mpfr
depends = mpfi
depends = sollya
+ depends = gsl
depends = libfplll
depends = libxml2
- source = https://gforge.inria.fr/frs/download.php/32591/flopoco-2.5.0.tgz
- md5sums = a7908528a6bf0e90c372bbab14319d8a
+ source = https://gforge.inria.fr/frs/download.php/file/36442/flopoco-4.1.tgz
+ md5sums = 0f7c7c85686649deacc36128754c1a7f
pkgname = flopoco
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a549098c4cf6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,10 @@
+
+src
+pkg
+
+*.pkg
+*.gz
+*.tar
+*.tgz
+*.xz
+
diff --git a/PKGBUILD b/PKGBUILD
index 12b1a330af5c..bc3c1e471b71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=flopoco
-pkgver=2.5.0
+pkgver=4.1
pkgrel=1
pkgdesc="A generator of arithmetic cores (Floating-Point Cores, but not only) for FPGAs (but not only)"
@@ -8,16 +8,17 @@ arch=('any')
url="http://flopoco.gforge.inria.fr/"
license=('custom')
-depends=('mpfr' 'mpfi' 'sollya' 'libfplll' 'libxml2')
+depends=('mpfr' 'mpfi' 'sollya' 'gsl' 'libfplll' 'libxml2')
makedepends=('cmake' 'boost')
-source=(https://gforge.inria.fr/frs/download.php/32591/flopoco-2.5.0.tgz)
-md5sums=('a7908528a6bf0e90c372bbab14319d8a')
+source=(https://gforge.inria.fr/frs/download.php/file/36442/flopoco-4.1.tgz)
+md5sums=('0f7c7c85686649deacc36128754c1a7f')
build() {
cd "$pkgname-$pkgver"
cmake -DCMAKE_INSTALL_PREFIX=/usr
make
+ ./flopoco BuildAutocomplete
}
package() {
@@ -25,10 +26,11 @@ package() {
install -D ./flopoco $pkgdir/usr/bin/flopoco
install -D ./bin2fp $pkgdir/usr/bin/flopoco_bin2fp
+ install -D ./binIEEE7542fp $pkgdir/usr/bin/flopoco_binIEEE7542fp
install -D ./fp2bin $pkgdir/usr/bin/flopoco_fp2bin
- install -D ./fpadder_example $pkgdir/usr/bin/flopoco_fpadder_example
+ install -D ./fp2binIEEE754 $pkgdir/usr/bin/flopoco_fp2binIEEE754
install -D ./longacc2fp $pkgdir/usr/bin/flopoco_longacc2fp
- install -D "./tools/FloPoCo Bash Completion/flopoco" $pkgdir/etc/bash_completion.d/flopoco
+ install -D ./flopoco_autocomplete $pkgdir/etc/bash_completion.d/flopoco
}