summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrien Prost-Boucle2015-06-24 08:22:04 +0200
committerAdrien Prost-Boucle2015-06-24 08:22:04 +0200
commitca454b9001bca2b71e49cc388a103a87f5fb6736 (patch)
treeeceeb473b5b539cb67a581f5232d1d16705cf938
downloadaur-ca454b9001bca2b71e49cc388a103a87f5fb6736.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6f940653d53d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = flopoco
+ pkgdesc = A generator of arithmetic cores (Floating-Point Cores, but not only) for FPGAs (but not only)
+ pkgver = 2.5.0
+ pkgrel = 1
+ url = http://flopoco.gforge.inria.fr/
+ arch = any
+ license = custom
+ makedepends = cmake
+ makedepends = boost
+ depends = mpfr
+ depends = mpfi
+ depends = sollya
+ depends = libfplll
+ depends = libxml2
+ source = https://gforge.inria.fr/frs/download.php/32591/flopoco-2.5.0.tgz
+ md5sums = a7908528a6bf0e90c372bbab14319d8a
+
+pkgname = flopoco
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12b1a330af5c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+
+pkgname=flopoco
+pkgver=2.5.0
+pkgrel=1
+
+pkgdesc="A generator of arithmetic cores (Floating-Point Cores, but not only) for FPGAs (but not only)"
+arch=('any')
+url="http://flopoco.gforge.inria.fr/"
+license=('custom')
+
+depends=('mpfr' 'mpfi' 'sollya' 'libfplll' 'libxml2')
+makedepends=('cmake' 'boost')
+
+source=(https://gforge.inria.fr/frs/download.php/32591/flopoco-2.5.0.tgz)
+md5sums=('a7908528a6bf0e90c372bbab14319d8a')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -D ./flopoco $pkgdir/usr/bin/flopoco
+ install -D ./bin2fp $pkgdir/usr/bin/flopoco_bin2fp
+ install -D ./fp2bin $pkgdir/usr/bin/flopoco_fp2bin
+ install -D ./fpadder_example $pkgdir/usr/bin/flopoco_fpadder_example
+ install -D ./longacc2fp $pkgdir/usr/bin/flopoco_longacc2fp
+
+ install -D "./tools/FloPoCo Bash Completion/flopoco" $pkgdir/etc/bash_completion.d/flopoco
+}
+