summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI Jack2015-08-31 13:50:47 -0400
committerGI Jack2015-08-31 13:50:47 -0400
commit87d6fb5877c7395f21326147a5721e061cd890d9 (patch)
treebd854c406393caeeca99b7883d091fb0d05e36ad
downloadaur-87d6fb5877c7395f21326147a5721e061cd890d9.tar.gz
initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD41
-rw-r--r--florence_config.desktop10
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..46efe608c0be
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = florence05
+ pkgdesc = A configurable on-screen virtual keyboard(GTK2 version)
+ pkgver = 0.5.4
+ pkgrel = 2
+ url = http://sourceforge.net/projects/florence/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool>=0.23
+ makedepends = gstreamer>=0.10
+ depends = gtk2
+ depends = gconf>=2.0
+ depends = libglade>=2.0
+ depends = libxml2
+ depends = librsvg
+ depends = cairo
+ depends = gettext
+ depends = libxtst
+ optdepends = gnome-doc-utils
+ optdepends = libnotify
+ optdepends = libpanelapplet
+ provides = florence
+ conflicts = florence
+ source = http://nchc.dl.sourceforge.net/project/florence/florence/0.5.4-gtk2/florence-0.5.4.tar.bz2
+ source = florence_config.desktop
+ sha256sums = 26d33aa20d5fbf34ceeded4c41cb922d2988b6082e33d9acc46dd7bfe56d31a1
+ sha256sums = 501ae59aa37c0a3bf6f724d34b04a821984afc825e49760eac713e9cc5fd9bc9
+
+pkgname = florence05
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c54b3f9381c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+## Originals
+# Maintainer: Charon77 <evans.jahja@yahoo.com>
+# Contributor: debdj <debd92@gmail.com>
+
+# GTK2 fork:
+# GI Jack < iamjacksemail@hackermail.com>
+
+pkgname=florence05
+_pkgname=florence
+pkgver=0.5.4
+pkgrel=2
+pkgdesc="A configurable on-screen virtual keyboard(GTK2 version)"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/florence/"
+license=('GPL')
+depends=('gtk2' 'gconf>=2.0' 'libglade>=2.0' 'libxml2' 'librsvg' 'cairo' 'gettext' 'libxtst')
+makedepends=('intltool>=0.23' 'gstreamer>=0.10')
+optdepends=('gnome-doc-utils' 'libnotify' 'libpanelapplet')
+provides=('florence')
+conflicts=('florence')
+source=("http://nchc.dl.sourceforge.net/project/florence/florence/0.5.4-gtk2/florence-$pkgver.tar.bz2" "florence_config.desktop")
+sha256sums=('26d33aa20d5fbf34ceeded4c41cb922d2988b6082e33d9acc46dd7bfe56d31a1'
+ '501ae59aa37c0a3bf6f724d34b04a821984afc825e49760eac713e9cc5fd9bc9')
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ ./configure --prefix=/usr --without-panelapplet --without-docs --without-notification --disable-schemas-compile
+ #you might want to add --without-at-spi if you don't have at-spi, or simply install at-spi.
+
+ make || return 1
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make DESTDIR=${pkgdir} install || return 1
+
+ #add a menu entry for configuring florence
+ install -Dm 644 ${startdir}/florence_config.desktop ${pkgdir}/usr/share/applications/florence_config.desktop
+
+}
+
diff --git a/florence_config.desktop b/florence_config.desktop
new file mode 100644
index 000000000000..8cff4b204dc8
--- /dev/null
+++ b/florence_config.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=0.5.3
+Name=Florence Config
+Type=Application
+Comment=On-Screen Keyboard
+Exec=florence --config
+Icon=/usr/share/pixmaps/florence.svg
+Categories=Accessories;GTK;Utility;Accessibility
+GenericName=Florence Config
+