summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2022-05-15 21:27:05 +1000
committerRod Kay2022-05-15 21:27:05 +1000
commitfa1fb8628a5a9a2ddb67fc9aa2aaf3f2fe1e7bc7 (patch)
treeed8fbae2c39780bcd048f60c1c20d3d60d550913
parent48bf2945aff8de2238170f4933dd15204bc0eb8f (diff)
downloadaur-fa1fb8628a5a9a2ddb67fc9aa2aaf3f2fe1e7bc7.tar.gz
Update to version 2022.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD38
-rw-r--r--posix-signals.ads-patch11
-rw-r--r--posix-unsafe_process_primitives.ads-patch11
4 files changed, 57 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75251632e322..ae1b9eb8673d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,19 @@
pkgbase = florist
pkgdesc = An open-source implementation of IEEE Standard 1003.5b-1996, the POSIX Ada binding.
- pkgver = 2021
+ pkgver = 2022
pkgrel = 1
- url = https://github.com/Blady-Com/florist
- arch = any
+ url = https://github.com/AdaCore/florist
+ arch = i686
+ arch = x86_64
license = GPL3
depends = gcc-ada
options = staticlibs
options = !strip
- source = git+https://github.com/Blady-Com/florist.git
- sha1sums = SKIP
+ source = https://github.com/AdaCore/florist/archive/refs/tags/v22.0.0.tar.gz
+ source = posix-signals.ads-patch
+ source = posix-unsafe_process_primitives.ads-patch
+ sha256sums = 534eb65f01c4b89b366e1251ec1c13a03482574e580f08107f1ed8ad1994bc67
+ sha256sums = 85823c4d2453ce4f5b73dd64beb0297d38e4a0525d06fbbb697d405533864297
+ sha256sums = 48975e3b4c5e22d514df28951c62db9851b8799f874e36f1762c0d84b69261e3
pkgname = florist
diff --git a/PKGBUILD b/PKGBUILD
index 40ec023ba212..e43def01a225 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,46 @@
-# Maintainer: Rod Kay <charlie5 on #ada at freenode.net>
-# Contributor: Sietse van der Molen <sietse@vdmolen.eu>
+# Maintainer: Rod Kay <rodakay5 at gmail.com>
pkgname=florist
-pkgver=2021
+pkgver=2022
pkgrel=1
pkgdesc="An open-source implementation of IEEE Standard 1003.5b-1996, the POSIX Ada binding."
-arch=('any')
-url="https://github.com/Blady-Com/florist"
+arch=('i686' 'x86_64')
+url="https://github.com/AdaCore/florist"
license=('GPL3')
depends=('gcc-ada')
options=(staticlibs !strip)
-source=('git+https://github.com/Blady-Com/florist.git')
-sha1sums=(SKIP)
+source=(https://github.com/AdaCore/florist/archive/refs/tags/v22.0.0.tar.gz
+ posix-signals.ads-patch
+ posix-unsafe_process_primitives.ads-patch)
+sha256sums=(534eb65f01c4b89b366e1251ec1c13a03482574e580f08107f1ed8ad1994bc67
+ 85823c4d2453ce4f5b73dd64beb0297d38e4a0525d06fbbb697d405533864297
+ 48975e3b4c5e22d514df28951c62db9851b8799f874e36f1762c0d84b69261e3)
+
+
+prepare()
+{
+ cd "$srcdir/florist-22.0.0"
+
+ patch -p0 -i ../posix-signals.ads-patch
+ patch -p0 -i ../posix-unsafe_process_primitives.ads-patch
+}
build()
{
- cd "$srcdir/$pkgname"
+ cd "$srcdir/florist-22.0.0"
- ./configure --prefix=$pkgdir/usr
- PROCESSORS="$(nproc)" make
+ ./configure --prefix=$pkgdir/usr --with-build-type=Production
+ PROCESSORS="$(nproc)" make
}
package()
{
- cd "$srcdir/$pkgname"
+ cd "$srcdir/florist-22.0.0"
- make DESTDIR="$pkgdir/" install
-}
+ make DESTDIR="$pkgdir/" install
+} \ No newline at end of file
diff --git a/posix-signals.ads-patch b/posix-signals.ads-patch
new file mode 100644
index 000000000000..96a83fde5860
--- /dev/null
+++ b/posix-signals.ads-patch
@@ -0,0 +1,11 @@
+--- libsrc/threads/posix-signals.ads 2022-05-15 00:20:45.817231036 +1000
++++ libsrc/threads/posix-signals.ads-new 2022-05-15 00:18:52.427234869 +1000
+@@ -36,7 +36,7 @@
+
+ with Ada.Task_Identification,
+ Ada.Finalization,
+- POSIX,
++-- POSIX,
+ POSIX.C,
+ POSIX.Process_Identification,
+ System,
diff --git a/posix-unsafe_process_primitives.ads-patch b/posix-unsafe_process_primitives.ads-patch
new file mode 100644
index 000000000000..cf5fe211e800
--- /dev/null
+++ b/posix-unsafe_process_primitives.ads-patch
@@ -0,0 +1,11 @@
+--- libsrc/posix-unsafe_process_primitives.ads 2022-05-15 00:20:13.418232131 +1000
++++ libsrc/posix-unsafe_process_primitives.ads-new 2022-05-15 00:18:18.771236007 +1000
+@@ -34,7 +34,7 @@
+ -- --
+ ------------------------------------------------------------------------------
+
+-with POSIX,
++with -- POSIX,
+ POSIX.Process_Environment,
+ POSIX.Process_Identification;
+ package POSIX.Unsafe_Process_Primitives is