summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2023-03-04 12:31:30 +0100
committerDaniel Peukert2023-03-04 12:31:30 +0100
commit3cad203948579cfe9b1fb1bbf1720564829aff85 (patch)
tree5b590bc348b2151d66b22801b05ac4d4c05aa0b7
parentdd72e723edb386f2f1ad7b7fd52374e804fa5bef (diff)
downloadaur-3cad203948579cfe9b1fb1bbf1720564829aff85.tar.gz
Remove unnecessary checkdep, include libflowparser files
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD19
2 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19026c043950..0d618ed74074 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = flow-git
pkgdesc = A static type checker for JavaScript - git version
- pkgver = 0.196.0.r14893.gf4ecc9c1f
+ pkgver = 0.201.0.r15454.gb43df2306
pkgrel = 1
url = https://flow.org
arch = x86_64
@@ -8,7 +8,6 @@ pkgbase = flow-git
arch = armv7h
arch = aarch64
license = MIT
- checkdepends = ocaml-ounit
makedepends = git
makedepends = ocaml>=4.14.0
makedepends = dune>=3.0.0
diff --git a/PKGBUILD b/PKGBUILD
index 5e85d42179ac..15ccde02950f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,13 @@
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
_pkgname='flow'
pkgname="$_pkgname-git"
-pkgver='0.196.0.r14893.gf4ecc9c1f'
+pkgver='0.201.0.r15454.gb43df2306'
pkgrel='1'
pkgdesc='A static type checker for JavaScript - git version'
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
url="https://$_pkgname.org"
license=('MIT')
makedepends=('git' 'ocaml>=4.14.0' 'dune>=3.0.0' 'ocaml-base>=0.14.1' 'ocaml-core_kernel>=0.14.1' 'ocaml-dtoa>=0.3.2' 'ocaml-fileutils>=0.6.3' 'ocaml-inotify>=2.4.1' 'ocaml-lwt>=5.4.0' 'ocaml-lwt_log>=1.1.1' 'ocaml-ppx_deriving' 'ocaml-ppx_gen_rec' 'ocaml-ppx_let>=0.14.0' 'ocaml-ppxlib' 'ocaml-sedlex>=2.3' 'ocaml-visitors' 'ocaml-wtf8')
-checkdepends=('ocaml-ounit')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("$pkgname::git+https://github.com/facebook/$_pkgname")
@@ -27,8 +26,9 @@ pkgver() {
build() {
cd "$srcdir/$_sourcedirectory/"
- # use the default ocaml behaviour to ignore warnings that upstream escalates to errors for some reason
- OCAMLPARAM='_,warn-error=-a+31' make
+ # Use the default ocaml behaviour to ignore warnings that upstream escalates to errors for some reason, use release build mode
+ OCAMLPARAM='_,warn-error=-a+31' FLOW_RELEASE=1 make
+ OCAMLPARAM='_,warn-error=-a+31' FLOW_RELEASE=1 make -C src/parser dist/libflowparser.zip
}
check() {
@@ -38,7 +38,18 @@ check() {
package() {
cd "$srcdir/$_sourcedirectory/"
+
+ # Binary
install -Dm755 "bin/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+
+ # Parser library files
+ install -dm755 "$pkgdir/usr/lib/ocaml/${_pkgname}parser/"
+ install -Dm644 "src/parser/dist/lib${_pkgname}parser/include/${_pkgname}parser/"* "$pkgdir/usr/lib/ocaml/${_pkgname}parser/"
+
+ install -dm755 "$pkgdir/usr/lib/"
+ install -Dm644 "src/parser/dist/lib${_pkgname}parser/lib/"* "$pkgdir/usr/lib/"
+
+ # Misc files
install -Dm644 'resources/shell/bash-completion' "$pkgdir/usr/share/bash-completion/completions/$_pkgname"
install -Dm644 'LICENSE' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}