summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-07-08 23:08:53 +0200
committerDaniel Peukert2020-07-08 23:08:53 +0200
commitd33c20cb7d160408abb0dac633b4a221fd1f8b37 (patch)
treeedc3e194492cba0633f1d1ef20b0085670d56489
parentcd25f75edab1c1e0193a20a51df7e700bdb83ee9 (diff)
downloadaur-d33c20cb7d160408abb0dac633b4a221fd1f8b37.tar.gz
Added flow-git
-rw-r--r--.SRCINFO37
-rw-r--r--.editorconfig8
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD54
4 files changed, 85 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 415e7ccbfa55..fc10ab567eef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,37 @@
-# Generated by mksrcinfo v8
-# Sat Dec 3 06:19:44 UTC 2016
pkgbase = flow-git
- pkgdesc = A realtime log analyzer .
- pkgver = 0.3.4.98
+ pkgdesc = A static type checker for JavaScript - git version
+ pkgver = 0.129.0.r10753.g547988d89
pkgrel = 1
- url = https://github.com/viseztrance/flow
+ url = https://flow.org/
arch = x86_64
arch = i686
- license = GPL-3.0
- makedepends = cargo
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ checkdepends = ocaml-ounit
+ makedepends = git
+ makedepends = ocaml>=4.07.1
+ makedepends = dune
+ makedepends = ocamlbuild
+ makedepends = ocaml-findlib
+ makedepends = ocaml-base>=0.11.1
+ makedepends = ocaml-dtoa>=0.3.1
+ makedepends = ocaml-lwt>=4.5.0
+ makedepends = ocaml-lwt_log>=1.1.0
+ makedepends = ocaml-migrate-parsetree
+ makedepends = ocaml-ppx_deriving
+ makedepends = ocaml-ppx_gen_rec
+ makedepends = ocaml-ppx_let>=0.11.0
+ makedepends = ocaml-ppx_tools_versioned
+ makedepends = ocaml-sedlex>=2.1
+ makedepends = ocaml-visitors
+ makedepends = ocaml-wtf8
+ optdepends = bash-completion: Bash completion
provides = flow
conflicts = flow
- source = flow-git::git+https://github.com/viseztrance/flow.git
+ source = flow-git::git+https://github.com/facebook/flow
sha256sums = SKIP
pkgname = flow-git
-
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..a467ee9a97a6
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,8 @@
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+insert_final_newline = true
+indent_style = tab
+tab_width = 4
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..82b3c183d5d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+*/
diff --git a/PKGBUILD b/PKGBUILD
index 5f36b49db014..f2288a60a1f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,45 @@
-pkgname=flow-git
-pkgver=0.3.4.98
-pkgrel=1
-pkgdesc="A realtime log analyzer ."
-arch=('x86_64' 'i686')
-url="https://github.com/viseztrance/flow"
-license=('GPL-3.0')
-depends=()
-makedepends=('cargo')
-optdepends=()
-provides=('flow')
-conflicts=('flow')
-source=($pkgname::git+https://github.com/viseztrance/flow.git)
+# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+# Contributor: Joel Goguen <contact+aur@jgoguen.ca>
+# Contributor: Vlad M. <vlad@archlinex.net>
+# Contributor: Gordin <9ordin @t gmail>
+# Contributor: Andy Weidenbaum <archbaum@gmail.com>
+_pkgname='flow'
+pkgname="$_pkgname-git"
+pkgver='0.129.0.r10753.g547988d89'
+pkgrel='1'
+pkgdesc='A static type checker for JavaScript - git version'
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="https://$_pkgname.org/"
+license=('MIT')
+optdepends=('bash-completion: Bash completion')
+makedepends=('git' 'ocaml>=4.07.1' 'dune' 'ocamlbuild' 'ocaml-findlib' 'ocaml-base>=0.11.1' 'ocaml-dtoa>=0.3.1' 'ocaml-lwt>=4.5.0' 'ocaml-lwt_log>=1.1.0' 'ocaml-migrate-parsetree' 'ocaml-ppx_deriving' 'ocaml-ppx_gen_rec' 'ocaml-ppx_let>=0.11.0' 'ocaml-ppx_tools_versioned' 'ocaml-sedlex>=2.1' 'ocaml-visitors' 'ocaml-wtf8')
+checkdepends=('ocaml-ounit')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$pkgname::git+https://github.com/facebook/$_pkgname")
sha256sums=('SKIP')
+_sourcedirectory="$pkgname"
+
pkgver() {
- cd $pkgname
- echo $(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).$(git rev-list --count HEAD)
+ cd "$srcdir/$_sourcedirectory/"
+ printf '%s.r%s.g%s' "$(sed -nE 's/^version: "([0-9.]*)"$/\1/p' 'flowtype.opam')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd $pkgname
- cargo build --release
+ cd "$srcdir/$_sourcedirectory"
+ # ignore warnings that upstream escalates to errors for some reason
+ OCAMLPARAM='_,warn-error=-60-67' make
+}
+
+check() {
+ cd "$srcdir/$_sourcedirectory/"
+ ./runtests.sh "bin/$_pkgname"
}
package() {
- cd $pkgname
- install -D -m755 "$srcdir/$pkgname/target/release/flow" "$pkgdir/usr/bin/flow"
+ cd "$srcdir/$_sourcedirectory"
+ install -Dm755 "bin/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 'resources/shell/bash-completion' "$pkgdir/usr/share/bash-completion/completions/$_pkgname"
+ install -Dm644 'LICENSE' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}