summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2017-01-31 20:05:30 -0800
committerLlewelyn Trahaearn2017-01-31 20:05:30 -0800
commit99845d9359834f24bad0ed6bf21889f9f39cbb20 (patch)
tree0e6c633de5c8973ea4f815587f8d6e728e0c6b94
downloadaur-99845d9359834f24bad0ed6bf21889f9f39cbb20.tar.gz
Import flowcanvas for ladish after it was dropped from the Community repository.
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD44
-rw-r--r--flowcanvas.install11
-rw-r--r--graphviz-2.30.patch56
4 files changed, 133 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d1bd5cb4ff05
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Wed Feb 1 04:04:24 UTC 2017
+pkgbase = flowcanvas
+ pkgdesc = Gtkmm/Gnomecanvasmm widget for boxes-and-lines style environments
+ pkgver = 0.7.1
+ pkgrel = 5
+ url = http://drobilla.net/software/flowcanvas/
+ install = flowcanvas.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = boost
+ makedepends = python2
+ depends = libgnomecanvasmm
+ depends = graphviz>=2.34
+ source = http://download.drobilla.net/flowcanvas-0.7.1.tar.bz2
+ source = graphviz-2.30.patch
+ md5sums = a4908f6385ce9fd2ce97c8caa823f053
+ md5sums = e5b2b23d8be0c9fa14b8b52379a15155
+
+pkgname = flowcanvas
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c6863841e21
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Llewelyn Trahaearn <woefulderelict [at] gmail [dot] com>
+# Contributor: Ray Rashif <schiv [at] archlinux [dot] org>
+# Contributor: Max a.k.a. Synthead <synthead [at] gmail [dot] com>
+# Contributor: christhemonkey <christhemonkey [at] gmail [dot] com>
+
+pkgname=flowcanvas
+pkgver=0.7.1
+pkgrel=5
+pkgdesc="Gtkmm/Gnomecanvasmm widget for boxes-and-lines style environments"
+arch=('i686' 'x86_64')
+url="http://drobilla.net/software/flowcanvas/"
+depends=('libgnomecanvasmm' 'graphviz>=2.34')
+makedepends=('boost' 'python2')
+license=('GPL')
+install=$pkgname.install
+source=("http://download.drobilla.net/$pkgname-$pkgver.tar.bz2"
+ "graphviz-2.30.patch")
+md5sums=('a4908f6385ce9fd2ce97c8caa823f053'
+ 'e5b2b23d8be0c9fa14b8b52379a15155')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # graphviz 2.30 compatibility
+ # see http://dev.drobilla.net/ticket/888
+ # adapted from FreeBSD patch (just stripped their stuff)
+ # potentially unstable (nothing committed by developer yet)
+ # may have to incorporate proposed patch for ganv (successor to this lib)
+ patch -Np0 -i "$srcdir/graphviz-2.30.patch"
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ CXXFLAGS+=' -std=c++11'
+ python2 waf configure --prefix=/usr
+ python2 waf build $MAKEFLAGS
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ python2 waf install --destdir="$pkgdir"
+}
diff --git a/flowcanvas.install b/flowcanvas.install
new file mode 100644
index 000000000000..806b209a93f7
--- /dev/null
+++ b/flowcanvas.install
@@ -0,0 +1,11 @@
+post_install() {
+ \ldconfig
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/graphviz-2.30.patch b/graphviz-2.30.patch
new file mode 100644
index 000000000000..1338a6832864
--- /dev/null
+++ b/graphviz-2.30.patch
@@ -0,0 +1,56 @@
+--- src/Canvas.cpp.orig 2011-01-10 00:19:58.000000000 +0100
++++ src/Canvas.cpp 2013-03-16 13:45:17.797462753 +0100
+@@ -1253,21 +1253,21 @@
+ */
+
+ GVC_t* gvc = gvContext();
+- Agraph_t* G = agopen((char*)"g", AGDIGRAPH);
++ Agraph_t* G = agopen((char*)"g", Agdirected, NULL);
+
+ nodes.gvc = gvc;
+ nodes.G = G;
+
+ if (_direction == HORIZONTAL)
+- agraphattr(G, (char*)"rankdir", (char*)"LR");
++ agattr(G, AGRAPH, (char*)"rankdir", (char*)"LR");
+ else
+- agraphattr(G, (char*)"rankdir", (char*)"TD");
++ agattr(G, AGRAPH, (char*)"rankdir", (char*)"TD");
+
+ unsigned id = 0;
+ for (ItemList::const_iterator i = _items.begin(); i != _items.end(); ++i) {
+ std::ostringstream ss;
+ ss << "n" << id++;
+- Agnode_t* node = agnode(G, strdup(ss.str().c_str()));
++ Agnode_t* node = agnode(G, strdup(ss.str().c_str()), true);
+ if (boost::dynamic_pointer_cast<Module>(*i)) {
+ ss.str("");
+ ss << (*i)->width() / 96.0;
+@@ -1310,7 +1310,7 @@
+
+ assert(src_node && dst_node);
+
+- Agedge_t* edge = agedge(G, src_node, dst_node);
++ Agedge_t* edge = agedge(G, src_node, dst_node, NULL, true);
+
+ if (use_length_hints && c->length_hint() != 0) {
+ std::ostringstream len_ss;
+@@ -1325,7 +1325,7 @@
+ if (partner) {
+ GVNodes::iterator p = nodes.find(partner);
+ if (p != nodes.end())
+- agedge(G, i->second, p->second);
++ agedge(G, i->second, p->second, NULL, true);
+ }
+ }
+
+--- wscript.orig 2011-01-12 00:09:31.000000000 +0100
++++ wscript 2013-03-16 14:19:43.577462602 +0100
+@@ -41,6 +41,7 @@
+ conf.check_tool('compiler_cxx')
+ autowaf.check_pkg(conf, 'libgvc', uselib_store='AGRAPH',
+ atleast_version='2.8', mandatory=False)
++ conf.env['LIB_AGRAPH'] = ['cgraph' if l == 'graph' else l for l in conf.env['LIB_AGRAPH']]
+ autowaf.check_pkg(conf, 'gtkmm-2.4', uselib_store='GLIBMM',
+ atleast_version='2.10.0', mandatory=True)
+ autowaf.check_pkg(conf, 'libgnomecanvasmm-2.6', uselib_store='GNOMECANVASMM',