summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomZ2020-05-27 00:02:03 +0200
committerTomZ2020-05-27 00:02:03 +0200
commitc090309c0694f5b7ef84b27a3cedee327e5a10fc (patch)
treeb6bc83044e61f8da5dd5ba2fe5a70053c63e8f0d
parentf1a21251f93b87caaf40b56a424f3b948894397f (diff)
downloadaur-c090309c0694f5b7ef84b27a3cedee327e5a10fc.tar.gz
introduce flowee-libs
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8bbf6964269a..308247dd92f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,6 +13,7 @@ pkgbase = flowee-git
depends = libevent
depends = openssl
provides = flowee-hub
++ provides = flowee-libs
backup = etc/flowee/flowee.conf
source = git+https://gitlab.com/FloweeTheHub/thehub.git#branch=master
source = flowee.logrotate
diff --git a/PKGBUILD b/PKGBUILD
index 866df6b38d4f..2fcff5174323 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ url="https://flowee.org/"
license=('GPL')
depends=('boost-libs' 'libevent' 'openssl')
makedepends=('boost' 'cmake' 'pkgconf')
-provides=('flowee-hub')
+provides=('flowee-hub' 'flowee-libs')
backup=("etc/flowee/flowee.conf")
install=flowee.install
source=("git+https://gitlab.com/FloweeTheHub/thehub.git#branch=master"
@@ -30,7 +30,7 @@ pkgver() {
build() {
mkdir -p build
cd build
- cmake -Dbuild_tests=true -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=$pkgdir/usr/ ../thehub
+ cmake -Denable_gui=false -Dbuild_tests=true -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=$pkgdir/usr/ ../thehub
make
}