summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomZ2022-05-03 21:19:07 +0200
committerTomZ2022-05-04 13:02:07 +0200
commit431ed1e85cf06736fbae19e331b5186365e0a05e (patch)
tree2f7e89a4be3e82967fdd3ad27b086eac115fe29d
parentc4ff57ebff66e31e9a628b15f5a2c491f5a98c7e (diff)
downloadaur-431ed1e85cf06736fbae19e331b5186365e0a05e.tar.gz
New release
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
-rw-r--r--flowee-pay.install7
3 files changed, 20 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1201ac772ab..c6f12c8851ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = flowee-pay
pkgdesc = Flowee Payment solution
- pkgver = 2021.07.1
+ pkgver = 2022.05.0
pkgrel = 1
url = http://flowee.org/
+ install = flowee-pay.install
arch = x86_64
arch = aarch64
license = GPL3
makedepends = boost
makedepends = cmake
- makedepends = flowee>=2021.06.0
+ makedepends = flowee>=2022.04.0
depends = qt5-base
provides = flowee-pay
- source = https://gitlab.com/FloweeTheHub/pay/-/archive/2021.07.1/pay-2021.07.1.tar.gz
+ source = https://gitlab.com/FloweeTheHub/pay/-/archive/2022.05.0/pay-2022.05.0.tar.gz
source = https://flowee.org/products/pay/blockheaders
- sha256sums = cbf5c57fa84169f156f6e01daa05d37bcf3a7a03e40c5abd1c9499a993d864ef
+ sha256sums = 085c9a5dd1b0c918c1e6fe9d5d4e8c47befceecc7631c26dcba9a4c4a7eb0ba5
sha256sums = 8c2dfde998b4472aea25daa1e4bfe7bcca0b765145ee740bd8cfb0152400abce
pkgname = flowee-pay
diff --git a/PKGBUILD b/PKGBUILD
index c89bfe667365..14d0084ef7f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,25 @@
# Maintainer: Tom Zander
pkgname=flowee-pay
-pkgver=2021.07.1
+pkgver=2022.05.0
pkgrel=1
pkgdesc="Flowee Payment solution"
arch=('x86_64' 'aarch64')
url="http://flowee.org/"
license=('GPL3')
depends=('qt5-base')
-makedepends=('boost' 'cmake' 'flowee>=2021.06.0')
+makedepends=('boost' 'cmake' 'flowee>=2022.04.0')
provides=('flowee-pay')
+install=flowee-pay.install
source=("https://gitlab.com/FloweeTheHub/pay/-/archive/$pkgver/pay-$pkgver.tar.gz"
"https://flowee.org/products/pay/blockheaders")
-sha256sums=('cbf5c57fa84169f156f6e01daa05d37bcf3a7a03e40c5abd1c9499a993d864ef'
+sha256sums=('085c9a5dd1b0c918c1e6fe9d5d4e8c47befceecc7631c26dcba9a4c4a7eb0ba5'
'8c2dfde998b4472aea25daa1e4bfe7bcca0b765145ee740bd8cfb0152400abce')
build() {
mkdir -p build
cd build
- cmake -DCMAKE_BUILD_TYPE:STRING=Release -DCMAKE_INSTALL_PREFIX=$pkgdir/usr/ ../pay-$pkgver
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=$pkgdir/usr/ ../pay-$pkgver
make
}
@@ -30,7 +31,9 @@ check() {
package() {
cd build
make install
+ # de-install pay_mobile
+ rm -f "$pkgdir/bin/flowee_mobile"
+ # install blockheaders to avoid first-run download
install -Dm 644 "$srcdir/blockheaders" -t "$pkgdir/usr/share/floweepay"
- install -Dm 644 "$srcdir/pay-$pkgver/data/bip39-english" -t "$pkgdir/usr/share/floweepay"
}
diff --git a/flowee-pay.install b/flowee-pay.install
new file mode 100644
index 000000000000..13845f96aba5
--- /dev/null
+++ b/flowee-pay.install
@@ -0,0 +1,7 @@
+post_install() {
+ /usr/bin/blockheaders-meta-extractor /usr/share/floweepay
+}
+
+post_upgrade() {
+ /usr/bin/blockheaders-meta-extractor /usr/share/floweepay
+}