summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2022-12-26 01:38:48 +0300
committerIgor Dyatlov2022-12-26 01:38:48 +0300
commit9aedc5599e1cc12f283e9779fe907317c2dd184c (patch)
tree69c2f30df5c4d4e0a29f834b902fecbfed38f4d1
parentbe14bf9f7e29addd3b964047f30766f4502b87bb (diff)
downloadaur-9aedc5599e1cc12f283e9779fe907317c2dd184c.tar.gz
Update
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
2 files changed, 18 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0cf762549964..3529f1a6b66d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = flowtime
pkgdesc = Get what motivates you done, without losing concentration
- pkgver = 2.5
+ pkgver = 3.0
pkgrel = 1
url = https://github.com/Diego-Ivan/Flowtime
arch = x86_64
arch = aarch64
license = GPL3
checkdepends = appstream-glib
+ makedepends = git
makedepends = meson
makedepends = vala
depends = gstreamer
depends = libadwaita
depends = libxml2
- source = https://github.com/Diego-Ivan/Flowtime/archive/v2.5.tar.gz
- b2sums = 09cc953138160c172470e8cea096b29dc985cb80f40513e642be694f21ba154743ef4dde68a5511fb2f7242622e14ee38582de818bda72b6a4fd06b1bdcf2590
+ depends = libgee
+ source = flowtime::git+https://github.com/Diego-Ivan/Flowtime.git#commit=aac2c1ecfc0d2081af9fa2f9010caa73486b937a
+ b2sums = SKIP
pkgname = flowtime
diff --git a/PKGBUILD b/PKGBUILD
index c35231664deb..4379a5ce2cf2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,31 @@
# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
pkgname=flowtime
-_pkgname=Flowtime
-pkgver=2.5
+pkgver=3.0
pkgrel=1
pkgdesc="Get what motivates you done, without losing concentration"
arch=('x86_64' 'aarch64')
url="https://github.com/Diego-Ivan/Flowtime"
license=('GPL3')
-depends=('gstreamer' 'libadwaita' 'libxml2')
-makedepends=('meson' 'vala')
+depends=('gstreamer' 'libadwaita' 'libxml2' 'libgee')
+makedepends=('git' 'meson' 'vala')
checkdepends=('appstream-glib')
-source=("${url}/archive/v${pkgver}.tar.gz")
-b2sums=('09cc953138160c172470e8cea096b29dc985cb80f40513e642be694f21ba154743ef4dde68a5511fb2f7242622e14ee38582de818bda72b6a4fd06b1bdcf2590')
+_commit=aac2c1ecfc0d2081af9fa2f9010caa73486b937a # tags/3.0^0
+source=("$pkgname::git+$url.git#commit=$_commit")
+b2sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
build() {
- arch-meson $_pkgname-$pkgver build
+ arch-meson $pkgname build
meson compile -C build
}
check() {
- meson test -C build || :
+ meson test -C build --print-errorlogs || :
}
package() {