summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 05:27:20 -0600
committerBrian Bidulock2015-06-10 05:27:20 -0600
commit4efe6c8617ddf308857c39672ab152306f7c7755 (patch)
tree6d058d31d9ece56f10f87e2b8b24029c86d93ef9
downloadaur-4efe6c8617ddf308857c39672ab152306f7c7755.tar.gz
initial version
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
-rw-r--r--fixes.patch64
-rw-r--r--flphoto.desktop13
-rw-r--r--flphoto.install11
5 files changed, 144 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3f7812840b30
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = flphoto
+ pkgdesc = Basic image management and display program based on the FLTK toolkit
+ pkgver = 1.3.1
+ pkgrel = 4
+ url = http://www.easysw.com/~mike/flphoto/
+ install = flphoto.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = fltk
+ depends = libgphoto2
+ depends = libcups
+ source = http://downloads.sourceforge.net/sourceforge/fltk/flphoto-1.3.1-source.tar.gz
+ source = fixes.patch
+ source = flphoto.desktop
+ md5sums = 5e02353cadfc07250731f34f24e83866
+ md5sums = 9664ac1af80f9871a9c17bb72dd019b4
+ md5sums = c8a81fe1ba9708d85c29972ad28057fd
+
+pkgname = flphoto
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..53ce8afd958e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Enrico Morelli <morelli@cerm.unifi.it>
+
+pkgname=flphoto
+pkgver=1.3.1
+pkgrel=4
+pkgdesc="Basic image management and display program based on the FLTK toolkit"
+arch=('i686' 'x86_64')
+url="http://www.easysw.com/~mike/flphoto/"
+license=('GPL')
+depends=('fltk' 'libgphoto2' 'libcups')
+install="flphoto.install"
+source=("http://downloads.sourceforge.net/sourceforge/fltk/$pkgname-$pkgver-source.tar.gz"
+ "fixes.patch"
+ "flphoto.desktop")
+md5sums=('5e02353cadfc07250731f34f24e83866'
+ '9664ac1af80f9871a9c17bb72dd019b4'
+ 'c8a81fe1ba9708d85c29972ad28057fd')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -Np2 -b -z .orig -i ../fixes.patch
+}
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make espmsg
+ make
+}
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm0644 "doc/flphoto.png" "$pkgdir/usr/share/pixmaps/flphoto.png"
+ install -Dm0644 "$srcdir/flphoto.desktop" "$pkgdir/usr/share/applications/flphoto.desktop"
+}
diff --git a/fixes.patch b/fixes.patch
new file mode 100644
index 000000000000..c5c860f2686d
--- /dev/null
+++ b/fixes.patch
@@ -0,0 +1,64 @@
+diff -up src/flphoto-1.3.1/camera.cxx.orig src/flphoto-1.3.1/camera.cxx
+--- src/flphoto-1.3.1/camera.cxx.orig 2006-07-17 19:11:22.000000000 -0600
++++ src/flphoto-1.3.1/camera.cxx 2014-03-24 00:42:21.000000000 -0600
+@@ -42,6 +42,8 @@
+ # define fl_mkdir(p) mkdir(p)
+ #else
+ # include <unistd.h>
++# include <sys/stat.h>
++# include <sys/types.h>
+ # define fl_mkdir(p) mkdir(p, 0777)
+ #endif // WIN32 && !__CYGWIN__
+ #include <errno.h>
+@@ -63,8 +65,7 @@
+ static void get_files(Camera *camera, const char *folder,
+ CameraList *list, GPContext *context);
+ static unsigned progress_start(GPContext *context, float target,
+- const char *format, va_list args,
+- void *data);
++ const char *format, void *data);
+ static void progress_update(GPContext *context, unsigned id, float current,
+ void *data);
+ static void purge_thumbnails(void);
+@@ -909,7 +910,6 @@ static unsigned // O - ID number
+ progress_start(GPContext *context, // I - Current context
+ float target, // I - Target size
+ const char *format, // I - Progress text, if any
+- va_list args, // I - Pointer to additional args
+ void *data) // I - Callback data
+ {
+ Fl_Progress *p = (Fl_Progress *)data;
+diff -up src/flphoto-1.3.1/Fl_Print_Dialog2.cxx.orig src/flphoto-1.3.1/Fl_Print_Dialog2.cxx
+--- src/flphoto-1.3.1/Fl_Print_Dialog2.cxx.orig 2006-11-26 14:45:08.000000000 -0700
++++ src/flphoto-1.3.1/Fl_Print_Dialog2.cxx 2014-03-24 00:40:44.000000000 -0600
+@@ -56,6 +56,7 @@
+
+ #ifdef HAVE_LIBCUPS
+ # include <cups/cups.h>
++# include <cups/ppd.h>
+ #endif // HAVE_LIBCUPS
+
+
+diff -up src/flphoto-1.3.1/image.cxx.orig src/flphoto-1.3.1/image.cxx
+--- src/flphoto-1.3.1/image.cxx.orig 2006-11-18 06:56:11.000000000 -0700
++++ src/flphoto-1.3.1/image.cxx 2014-03-24 00:40:44.000000000 -0600
+@@ -92,6 +92,7 @@ extern "C" {
+
+ #ifdef HAVE_LIBPNG
+ # include <png.h>
++# include <zlib.h>
+ #endif // HAVE_LIBPNG
+
+
+diff -up src/flphoto-1.3.1/Makefile.in.orig src/flphoto-1.3.1/Makefile.in
+--- src/flphoto-1.3.1/Makefile.in.orig 2006-11-19 08:51:00.000000000 -0700
++++ src/flphoto-1.3.1/Makefile.in 2014-03-24 00:40:44.000000000 -0600
+@@ -103,7 +103,7 @@ VPATH = $(srcdir)
+ # Targets...
+ #
+
+-TRANSLATIONS = po/de po/en_CA po/en_GB po/es po/fr po/it po/nl po/pt po/sv
++TRANSLATIONS = po/de po/en_CA po/en_GB po/es po/fr
+ TARGETS = \
+ fldcraw$(EXEEXT) \
+ flphoto$(EXEEXT) \
diff --git a/flphoto.desktop b/flphoto.desktop
new file mode 100644
index 000000000000..a8f35ef53a02
--- /dev/null
+++ b/flphoto.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Name=flPhoto
+Comment=FLTK Photo Album
+TryExec=flphoto
+Exec=flphoto %F
+Icon=flphoto
+Terminal=false
+Type=Application
+MimeType=application/x-flphoto;
+Patterns=*.album
+Encoding=UTF-8
+Categories=Graphics;Photography;
+StartupNotify=false
diff --git a/flphoto.install b/flphoto.install
new file mode 100644
index 000000000000..e111ef946053
--- /dev/null
+++ b/flphoto.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}