summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormads kjeldgaard2020-09-03 23:19:06 +0200
committermads kjeldgaard2020-09-03 23:19:06 +0200
commitd9d4cf14a864a6dbeb8f836d15e231d65bb00a0b (patch)
tree8e4d4fd6236fe9275fbc08273ce1eb68900fedc6
downloadaur-d9d4cf14a864a6dbeb8f836d15e231d65bb00a0b.tar.gz
Initial package commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD54
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f1bcbd01d2bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = flucoma-cli-git
+ pkgdesc = Fluid Corpus Manipulation Command line interface
+ pkgver = r106.5b49c0a
+ pkgrel = 1
+ url = https://github.com/flucoma/flucoma-cli
+ arch = x86_64
+ license = BSD
+ makedepends = cmake>=3.11
+ makedepends = git
+ makedepends = gcc
+ makedepends = gcc-libs
+ optdepends = python3: For documentation
+ optdepends = python-jinja: For documentation
+ optdepends = python-yaml: For documentation
+ optdepends = python-docutils: For documentation
+ provides = flucoma-cli-git
+ conflicts = flucoma-cli
+ source = flucoma-cli-git::git://github.com/flucoma/flucoma-cli.git
+ md5sums = SKIP
+
+pkgname = flucoma-cli-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23e01ff38342
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Mads Kjeldgaard <mail@madskjeldgaard.dk>
+pkgname=flucoma-cli-git
+pkgver=r106.5b49c0a
+pkgrel=1
+pkgdesc="Fluid Corpus Manipulation Command line interface"
+arch=('x86_64')
+url="https://github.com/flucoma/flucoma-cli"
+license=('BSD')
+depends=()
+makedepends=('cmake>=3.11' 'git' 'gcc' 'gcc-libs' )
+optdepends=('python3: For documentation'
+ 'python-jinja: For documentation'
+ 'python-yaml: For documentation'
+ 'python-docutils: For documentation')
+provides=("${pkgname}")
+conflicts=("flucoma-cli")
+options=()
+source=('flucoma-cli-git::git://github.com/flucoma/flucoma-cli.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname}"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname}"
+ mkdir -p build && cd build
+ cmake -DDOCS=OFF ..
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}"
+
+ install -Dm755 ./bin/fluid-ampgate "$pkgdir/usr/bin/fluid-ampgate"
+ install -Dm755 ./bin/fluid-ampslice "$pkgdir/usr/bin/fluid-ampslice"
+ install -Dm755 ./bin/fluid-hpss "$pkgdir/usr/bin/fluid-hpss"
+ install -Dm755 ./bin/fluid-loudness "$pkgdir/usr/bin/fluid-loudness"
+ install -Dm755 ./bin/fluid-melbands "$pkgdir/usr/bin/fluid-melbands"
+ install -Dm755 ./bin/fluid-mfcc "$pkgdir/usr/bin/fluid-mfcc"
+ install -Dm755 ./bin/fluid-nmf "$pkgdir/usr/bin/fluid-nmf"
+ install -Dm755 ./bin/fluid-noveltyslice "$pkgdir/usr/bin/fluid-noveltyslice"
+ install -Dm755 ./bin/fluid-onsetslice "$pkgdir/usr/bin/fluid-onsetslice"
+ install -Dm755 ./bin/fluid-pitch "$pkgdir/usr/bin/fluid-pitch"
+ install -Dm755 ./bin/fluid-sines "$pkgdir/usr/bin/fluid-sines"
+ install -Dm755 ./bin/fluid-spectralshape "$pkgdir/usr/bin/fluid-spectralshape"
+ install -Dm755 ./bin/fluid-stats "$pkgdir/usr/bin/fluid-stats"
+ install -Dm755 ./bin/fluid-transients "$pkgdir/usr/bin/fluid-transients"
+ install -Dm755 ./bin/fluid-transientslice "$pkgdir/usr/bin/fluid-transientslice"
+
+ install -Dm644 ./LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}