aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoost Molenaar2018-08-13 13:09:13 +0200
committerJoost Molenaar2018-08-13 13:22:15 +0200
commit65b1aa377c5752ad4bc88e22cb779a33536ae717 (patch)
tree2337ced262323d1a20fdaacc7b7c43da385b08b1
downloadaur-65b1aa377c5752ad4bc88e22cb779a33536ae717.tar.gz
Build version 0.13.7-1 of fluent-bit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD47
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4518df7a6764
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = fluent-bit
+ pkgdesc = Collect data/logs from different sources, unify and send them to multiple destinations.
+ pkgver = 0.13.7
+ pkgrel = 1
+ url = https://fluentbit.io/
+ arch = x86_64
+ license = Apache
+ makedepends = cmake
+ source = https://fluentbit.io/releases/0.13/fluent-bit-0.13.7.tar.gz
+ md5sums = 9c592bda1ba6fcee2d62f0e2737ab71d
+
+pkgname = fluent-bit
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c1f6cf7f1528
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+*.tar.gz
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80c5c317e4be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Joost Molenaar <jjm@j0057.nl>
+
+pkgname=fluent-bit
+
+pkgmaj=0.13
+pkgver=$pkgmaj.7
+pkgrel=1
+epoch=
+
+pkgdesc='Collect data/logs from different sources, unify and send them to multiple destinations.'
+arch=(x86_64)
+url='https://fluentbit.io/'
+license=('Apache')
+groups=()
+
+depends=()
+makedepends=(cmake)
+checkdepends=()
+optdepends=()
+
+provides=()
+conflicts=()
+replaces=()
+
+backup=()
+options=()
+install=
+changelog=
+source=("https://fluentbit.io/releases/$pkgmaj/$pkgname-$pkgver.tar.gz")
+noextract=()
+md5sums=(9c592bda1ba6fcee2d62f0e2737ab71d)
+validpgpkeys=()
+
+build() {
+ #cd "$pkgname-$pkgver"
+ #./configure --prefix=/usr
+ #make
+
+ cd $pkgname-$pkgver/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_SYSCONFDIR=/etc ..
+ make -j8
+}
+
+package() {
+ cd $pkgname-$pkgver/build
+ make DESTDIR="$pkgdir/" install
+}