summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-01-05 11:28:57 -0700
committerMark Wagie2022-01-05 11:28:57 -0700
commit65ead010bef1e5a59aae40ea53e610ad401d6fc4 (patch)
tree28683527b5a84008fd8f679ed6e447797d5bc4e5
parent35f8e6eaed14abe1a053a690caac0d21f14f3737 (diff)
downloadaur-65ead010bef1e5a59aae40ea53e610ad401d6fc4.tar.gz
add fluent-round-icon-theme-git, correct dependencies
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD22
2 files changed, 33 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4676eebfd6e2..deecebaa2941 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = fluent-icon-theme-git
- pkgver = 2021.08.15.r2.g381a55d
- pkgrel = 1
+ pkgver = 2021.12.20.r1.g7004850
+ pkgrel = 2
arch = any
license = GPL3
makedepends = git
- depends = hicolor-icon-theme
- depends = gtk-update-icon-cache
+ makedepends = gtk-update-icon-cache
options = !strip
source = fluent-icon-theme::git+https://github.com/vinceliuice/Fluent-icon-theme.git
sha256sums = SKIP
@@ -13,11 +12,24 @@ pkgbase = fluent-icon-theme-git
pkgname = fluent-icon-theme-git
pkgdesc = A Fluent design icon theme
url = https://www.pling.com/p/1477945
+ depends = hicolor-icon-theme
+ depends = gtk-update-icon-cache
+ provides = fluent-icon-theme
+ conflicts = fluent-icon-theme
+
+pkgname = fluent-round-icon-theme-git
+ pkgdesc = A Fluent design icon theme (round version)
+ url = https://www.pling.com/p/1477945
+ depends = hicolor-icon-theme
+ depends = gtk-update-icon-cache
+ provides = fluent-round-icon-theme
provides = fluent-icon-theme
+ conflicts = fluent-round-icon-theme
conflicts = fluent-icon-theme
pkgname = fluent-cursor-theme-git
pkgdesc = An x-cursor theme inspired by Qogir theme and based on capitaine-cursors.
url = https://www.pling.com/p/1499852
+ depends = libxcursor
provides = fluent-cursor-theme
conflicts = fluent-cursor-theme
diff --git a/PKGBUILD b/PKGBUILD
index 6828f6951f05..75963ca85125 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,11 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
-pkgname=('fluent-icon-theme-git' 'fluent-cursor-theme-git')
+pkgname=('fluent-icon-theme-git' 'fluent-round-icon-theme-git' 'fluent-cursor-theme-git')
pkgbase=fluent-icon-theme-git
-pkgver=2021.08.15.r2.g381a55d
-pkgrel=1
+pkgver=2021.12.20.r1.g7004850
+pkgrel=2
arch=('any')
license=('GPL3')
-depends=('hicolor-icon-theme' 'gtk-update-icon-cache')
-makedepends=('git')
+makedepends=('git' 'gtk-update-icon-cache')
options=('!strip')
source=("${pkgbase%-git}::git+https://github.com/vinceliuice/Fluent-icon-theme.git")
sha256sums=('SKIP')
@@ -19,6 +18,7 @@ pkgver() {
package_fluent-icon-theme-git() {
pkgdesc="A Fluent design icon theme"
url="https://www.pling.com/p/1477945"
+ depends=('hicolor-icon-theme' 'gtk-update-icon-cache')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -27,9 +27,21 @@ package_fluent-icon-theme-git() {
./install.sh -a -d "$pkgdir/usr/share/icons"
}
+package_fluent-round-icon-theme-git() {
+ pkgdesc="A Fluent design icon theme (round version)"
+ url="https://www.pling.com/p/1477945"
+ depends=('hicolor-icon-theme' 'gtk-update-icon-cache')
+ provides=("${pkgname%-git}" 'fluent-icon-theme')
+ conflicts=("${pkgname%-git}" 'fluent-icon-theme')
+
+ cd "$srcdir/${pkgbase%-git}"
+ ./install.sh -a -d "$pkgdir/usr/share/icons" -r
+}
+
package_fluent-cursor-theme-git() {
pkgdesc="An x-cursor theme inspired by Qogir theme and based on capitaine-cursors."
url="https://www.pling.com/p/1499852"
+ depends=('libxcursor')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")