summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTsiry Sandratraina2025-01-21 22:36:24 +0300
committerTsiry Sandratraina2025-01-21 22:36:24 +0300
commite8f8ca7b9d75efe2e3a9e934e1d96a80ede2f9aa (patch)
tree108fbdf675ad776af108695b05f282a79b41a776
downloadaur-e8f8ca7b9d75efe2e3a9e934e1d96a80ede2f9aa.tar.gz
Initial Commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD22
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ebf9b3ccfe20
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = fluentci
+ pkgdesc = Set up and run your CI locally or in any CI Provider in a consistent way
+ pkgver = 0.16.5
+ pkgrel = 1
+ url = https://github.com/fluentci-io/fluentci
+ arch = x86_64
+ license = MPL-2.0
+ depends = deno
+ options = !strip
+ source = git+https://github.com/fluentci-io/fluentci.git#tag=v0.16.5
+ sha256sums = SKIP
+
+pkgname = fluentci
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..de15c5baf796
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+Dockerfile
+.ssh \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4c23c7f7fd9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Tsiry Sandratraina <tsiry.sndr@fluentci.io>
+
+pkgname=fluentci
+pkgver=0.16.5
+pkgrel=1
+pkgdesc="Set up and run your CI locally or in any CI Provider in a consistent way"
+arch=('x86_64')
+url="https://github.com/fluentci-io/fluentci"
+license=('MPL-2.0')
+depends=('deno')
+source=("git+https://github.com/fluentci-io/fluentci.git#tag=v$pkgver")
+sha256sums=('SKIP')
+options=('!strip') # stripping breaks the binary
+
+build() {
+ cd "$srcdir/$pkgname"
+ deno compile -A --no-check main.ts -o fluentci
+}
+
+package() {
+ install -D -m 755 -t "${pkgdir}/usr/bin" "$srcdir/$pkgname/fluentci"
+} \ No newline at end of file