summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYoyPa2019-01-25 14:56:02 +0100
committerYoyPa2019-01-25 14:56:02 +0100
commitadf84ca9b012b58341ef5752e67e2c0d960335c4 (patch)
tree0a8e8e67813f46f2ef3172058b63f9b94124dc94
downloadaur-adf84ca9b012b58341ef5752e67e2c0d960335c4.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD24
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fb1affb0cc3b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = fluffy-switch
+ pkgdesc = Goldtree and Tinfoil GUI for USB install on switch
+ pkgver = 2.2
+ pkgrel = 1
+ url = https://github.com/fourminute/Fluffy
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = armv6h
+ arch = aarch64
+ license = GPL
+ depends = python-pyusb
+ depends = libusb
+ depends = python-pyqt5
+ optdepends = python-qdarkstyle: dark theme recommanded by author
+ source = Fluffy-2.2.tar.gz::https://github.com/fourminute/Fluffy/archive/v2.2.tar.gz
+ sha256sums = e1ee082985de616c5c83180f2fa7ce371a1ea7e1e92d991dd673d397a5557499
+
+pkgname = fluffy-switch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..023140c27bd8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: YoyPa <yoann dot p dot public at gmail dot com>
+pkgname=fluffy-switch
+pkgver=2.2
+pkgrel=1
+pkgdesc="Goldtree and Tinfoil GUI for USB install on switch"
+arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
+url="https://github.com/fourminute/Fluffy"
+license=('GPL')
+depends=(
+ 'python-pyusb'
+ 'libusb'
+ 'python-pyqt5'
+)
+optdepends=(
+ 'python-qdarkstyle: dark theme recommanded by author'
+)
+source=("Fluffy-${pkgver}.tar.gz::https://github.com/fourminute/Fluffy/archive/v${pkgver}.tar.gz")
+sha256sums=('e1ee082985de616c5c83180f2fa7ce371a1ea7e1e92d991dd673d397a5557499')
+
+package() {
+ cd "$Fluffy-$pkgver"
+ install -Dm 644 80-fluffy-switch.rules "$pkgdir/etc/udev/rules.d/80-fluffy-switch.rules
+ install -Dm 755 fluffy.pyw "$pkgdir/usr/bin/fluffy-switch
+} \ No newline at end of file