summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThe one with the braid2024-04-04 21:25:37 +0200
committerThe one with the braid2024-04-04 21:25:37 +0200
commit559400790a7085e37e900d8bd5fffb70c25acaa6 (patch)
treeb1f3b7c11d319932205116f3a9714f153dc8c8e6
parent0292fc627d30c97ae818c0e588dec566c8485382 (diff)
downloadaur-559400790a7085e37e900d8bd5fffb70c25acaa6.tar.gz
fix: add SQLCipher patch
Signed-off-by: The one with the braid <info@braid.business>
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
-rw-r--r--system-sqlcipher.patch26
3 files changed, 41 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2f41201fa9a..131eea9b297f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fluffychat
pkgdesc = Open. Nonprofit. Cute. Easy to use (matrix) messenger. Secure and decentralized.
pkgver = 1.19.0
- pkgrel = 3
+ pkgrel = 4
url = https://fluffychat.im/
arch = x86_64
arch = aarch64
@@ -14,9 +14,12 @@ pkgbase = fluffychat
depends = xdg-user-dirs
depends = libolm
depends = zenity
+ depends = openssl
provides = fluffychat
conflicts = fluffychat
source = fluffychat-v1.19.0.tar.gz::https://github.com/krille-chan/fluffychat/archive/refs/tags/v1.19.0.tar.gz
+ source = system-sqlcipher.patch
sha256sums = 0fb007f2ed56ee46115606dae5eb2bb9eac238c344caae8d478eb80d71e6295f
+ sha256sums = b5b2beb552414e692c4cf6def9d74e8327a968dc15747cc0fb794f226e6633e7
pkgname = fluffychat
diff --git a/PKGBUILD b/PKGBUILD
index 680c1721c490..cd8c32e442f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=fluffychat
pkgver=1.19.0
-pkgrel=3
+pkgrel=4
pkgdesc="Open. Nonprofit. Cute. Easy to use (matrix) messenger. Secure and decentralized."
arch=('x86_64' 'aarch64')
url="https://fluffychat.im/"
@@ -19,6 +19,8 @@ depends=(
'libolm'
# flutter_file_picker - see https://github.com/miguelpruivo/flutter_file_picker/blob/master/lib/src/linux/file_picker_linux.dart#L115
'zenity'
+ # sqlite encryption
+ 'openssl'
)
makedepends=(
'flutter-tool'
@@ -26,8 +28,12 @@ makedepends=(
)
provides=("$pkgname")
conflicts=("$pkgname")
-source=("fluffychat-v${pkgver}.tar.gz::https://github.com/krille-chan/fluffychat/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('0fb007f2ed56ee46115606dae5eb2bb9eac238c344caae8d478eb80d71e6295f')
+source=(
+ "fluffychat-v${pkgver}.tar.gz::https://github.com/krille-chan/fluffychat/archive/refs/tags/v${pkgver}.tar.gz"
+ "system-sqlcipher.patch"
+)
+sha256sums=('0fb007f2ed56ee46115606dae5eb2bb9eac238c344caae8d478eb80d71e6295f'
+ 'b5b2beb552414e692c4cf6def9d74e8327a968dc15747cc0fb794f226e6633e7')
prepare() {
# overriding CMake flags for aarch64 in order to ensure build
@@ -42,11 +48,12 @@ prepare() {
cd ${pkgname}-$pkgver
flutter pub get
+ patch --follow-symlinks -p1 -i "${srcdir}/system-sqlcipher.patch" -d .
}
build() {
cd ${pkgname}-$pkgver
- flutter build linux --release --verbose
+ flutter build linux --no-pub --release --verbose
}
package() {
diff --git a/system-sqlcipher.patch b/system-sqlcipher.patch
new file mode 100644
index 000000000000..02e17bcc426c
--- /dev/null
+++ b/system-sqlcipher.patch
@@ -0,0 +1,26 @@
+--- ./pubspec.lock.orig
++++ ./pubspec.lock
+@@ -1799,10 +1799,10 @@
+ dependency: "direct main"
+ description:
+ name: sqlcipher_flutter_libs
+- sha256: e2d4dde4288c7fd1fd1cc0b1d39a9cf537ec236fed0c6dcd54b577543872a19d
++ sha256: "60fe3444ff5b1b298a9ca3003c6c7f1f7ee4c90aa6035a8647f3aeaf05a073e2"
+ url: "https://pub.dev"
+ source: hosted
+- version: "0.6.0"
++ version: "0.6.1"
+ sqlite3:
+ dependency: transitive
+ description:
+--- ./pubspec.yaml.orig
++++ ./pubspec.yaml
+@@ -83,7 +83,7 @@
+ shared_preferences: ^2.2.0 # Pinned because https://github.com/flutter/flutter/issues/118401
+ slugify: ^2.0.0
+ sqflite_common_ffi: ^2.3.0+4
+- sqlcipher_flutter_libs: ^0.6.0
++ sqlcipher_flutter_libs: ^0.6.1
+ swipe_to_action: ^0.2.0
+ tor_detector_web: ^1.1.0
+ uni_links: ^0.5.1