diff options
author | WithTheBraid | 2022-09-12 06:53:27 +0200 |
---|---|---|
committer | WithTheBraid | 2022-09-12 06:53:27 +0200 |
commit | 97e2932f730e0f3f6cc0a7418ed7cd90d80198b2 (patch) | |
tree | 9a6beda6cd7119d7ccd7013e5ec856228a79d127 | |
parent | 4d62fd6e04d1a2a5b8a2bfcd490f9f711c6b1a15 (diff) | |
download | aur-97e2932f730e0f3f6cc0a7418ed7cd90d80198b2.tar.gz |
fix: typo in environment variable
Signed-off-by: WithTheBraid <the-one@with-the-braid.cf>
-rw-r--r-- | PKGBUILD | 5 |
1 files changed, 2 insertions, 3 deletions
@@ -27,13 +27,12 @@ prepare() { # overriding CMake flags for aarch64 in order to ensure build # is not failing - if [[ "$arch" == "aarch64" ]]; then + if [ "$(uname -m)" == "aarch64" ]; then export CXXFLAGS="${CXXFLAGS/-fstack-protector-strong/ }" export CXXFLAGS="${CXXFLAGS/-fstack-clash-protection/ }" fi cd ${pkgname}-v$pkgver - flutter --no-version-check --suppress-analytics clean flutter --no-version-check --suppress-analytics pub get } @@ -43,7 +42,7 @@ build() { } package() { - case "$arch" in + case "$(uname -m)" in "x86_64") export FLUTTER_ARCH="x64" ;; |