summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWithTheBraid2022-09-12 07:01:27 +0200
committerWithTheBraid2022-09-12 07:01:27 +0200
commitd72c5ec8db5f1afcc177bab9257f14d7a45367ad (patch)
tree0e50b3f6ab174c165bc1a6a098edebc923c29cee
parent97e2932f730e0f3f6cc0a7418ed7cd90d80198b2 (diff)
downloadaur-d72c5ec8db5f1afcc177bab9257f14d7a45367ad.tar.gz
fix: typo in environment variable
Signed-off-by: WithTheBraid <the-one@with-the-braid.cf>
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2efb086c3095..e565c5123420 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,9 +27,12 @@ prepare() {
# overriding CMake flags for aarch64 in order to ensure build
# is not failing
- if [ "$(uname -m)" == "aarch64" ]; then
+ if [[ "$(uname -m)" == "aarch64" ]]; then
export CXXFLAGS="${CXXFLAGS/-fstack-protector-strong/ }"
export CXXFLAGS="${CXXFLAGS/-fstack-clash-protection/ }"
+
+ export CFLAGS="${CFLAGS/-fstack-protector-strong/ }"
+ export CFLAGS="${CFLAGS/-fstack-clash-protection/ }"
fi
cd ${pkgname}-v$pkgver