summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThe one with the braid2024-05-10 20:57:50 +0200
committerThe one with the braid2024-05-10 20:57:50 +0200
commite8e6f3c48cb032edcb7a665f9923c98b41647aaa (patch)
tree4076e469e6c4dbcb1a2374eace0bb69762d14575
parent2ab363f2e741269054e043b3cca0601d0988abe5 (diff)
downloadaur-e8e6f3c48cb032edcb7a665f9923c98b41647aaa.tar.gz
chore: bump version
Signed-off-by: The one with the braid <info@braid.business>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
-rw-r--r--openssl-dynamic-link.patch38
3 files changed, 5 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e340a91226a..5ffb11a556ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fluffychat
pkgdesc = Open. Nonprofit. Cute. Easy to use (matrix) messenger. Secure and decentralized.
- pkgver = 1.19.0
+ pkgver = 1.20.0
pkgrel = 5
url = https://fluffychat.im/
arch = x86_64
@@ -17,9 +17,7 @@ pkgbase = fluffychat
depends = openssl
provides = fluffychat
conflicts = fluffychat
- source = fluffychat-v1.19.0.tar.gz::https://github.com/krille-chan/fluffychat/archive/refs/tags/v1.19.0.tar.gz
- source = openssl-dynamic-link.patch
- sha256sums = 0fb007f2ed56ee46115606dae5eb2bb9eac238c344caae8d478eb80d71e6295f
- sha256sums = 30cabdeb108d7766b55c002978d8ef64df4dfba2e3e7b872de774727afa50730
+ source = fluffychat-v1.20.0.tar.gz::https://github.com/krille-chan/fluffychat/archive/refs/tags/v1.20.0.tar.gz
+ sha256sums = c8a0462a1729fc9feb7213af2266cc230dc61fad589b2507cdb4e8144a5fef19
pkgname = fluffychat
diff --git a/PKGBUILD b/PKGBUILD
index 282d4743ba59..8e80ee15120f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# thanks to celogeek, sseneca, dr460nf1r3, dr460nf1r3 and AverytheFurry for pointing out multiple things
pkgname=fluffychat
-pkgver=1.19.0
+pkgver=1.20.0
pkgrel=5
pkgdesc="Open. Nonprofit. Cute. Easy to use (matrix) messenger. Secure and decentralized."
arch=('x86_64' 'aarch64')
@@ -30,10 +30,8 @@ provides=("$pkgname")
conflicts=("$pkgname")
source=(
"fluffychat-v${pkgver}.tar.gz::https://github.com/krille-chan/fluffychat/archive/refs/tags/v${pkgver}.tar.gz"
- "openssl-dynamic-link.patch"
)
-sha256sums=('0fb007f2ed56ee46115606dae5eb2bb9eac238c344caae8d478eb80d71e6295f'
- '30cabdeb108d7766b55c002978d8ef64df4dfba2e3e7b872de774727afa50730')
+sha256sums=('c8a0462a1729fc9feb7213af2266cc230dc61fad589b2507cdb4e8144a5fef19')
prepare() {
# overriding CMake flags for aarch64 in order to ensure build
@@ -46,7 +44,6 @@ prepare() {
export CFLAGS="${CFLAGS/-fstack-clash-protection/ }"
fi
- patch --follow-symlinks -p1 -i "${srcdir}/openssl-dynamic-link.patch" -d "${srcdir}/${pkgname}-${pkgver}"
pushd "${srcdir}/${pkgname}-${pkgver}"
flutter pub get
}
diff --git a/openssl-dynamic-link.patch b/openssl-dynamic-link.patch
deleted file mode 100644
index ab3f8716ad9e..000000000000
--- a/openssl-dynamic-link.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- ./linux/CMakeLists.txt.orig
-+++ ./linux/CMakeLists.txt
-@@ -9,6 +9,9 @@
- # https://wiki.gnome.org/HowDoI/ChooseApplicationID
- set(APPLICATION_ID "chat.fluffy.fluffychat")
-
-+# dynamically link OpenSSL
-+set(OPENSSL_USE_STATIC_LIBS OFF)
-+
- # Explicitly opt in to modern CMake behaviors to avoid warnings with recent
- # versions of CMake.
- cmake_policy(SET CMP0063 NEW)
---- ./pubspec.lock.orig
-+++ ./pubspec.lock
-@@ -1799,10 +1799,10 @@
- dependency: "direct main"
- description:
- name: sqlcipher_flutter_libs
-- sha256: e2d4dde4288c7fd1fd1cc0b1d39a9cf537ec236fed0c6dcd54b577543872a19d
-+ sha256: "60fe3444ff5b1b298a9ca3003c6c7f1f7ee4c90aa6035a8647f3aeaf05a073e2"
- url: "https://pub.dev"
- source: hosted
-- version: "0.6.0"
-+ version: "0.6.1"
- sqlite3:
- dependency: transitive
- description:
---- ./pubspec.yaml.orig
-+++ ./pubspec.yaml
-@@ -83,7 +83,7 @@
- shared_preferences: ^2.2.0 # Pinned because https://github.com/flutter/flutter/issues/118401
- slugify: ^2.0.0
- sqflite_common_ffi: ^2.3.0+4
-- sqlcipher_flutter_libs: ^0.6.0
-+ sqlcipher_flutter_libs: ^0.6.1
- swipe_to_action: ^0.2.0
- tor_detector_web: ^1.1.0
- uni_links: ^0.5.1