summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheOneWithTheBraid2022-09-12 06:52:39 +0200
committerTheOneWithTheBraid2022-09-12 06:52:39 +0200
commit6f9f927e84b0db892234f5038d17f0af3b655db0 (patch)
tree33a5a24ae862d727eca516bd8e14923ea3fb0f98
parenta44d0fbaafec2c534b90deb9389acca5af9db05b (diff)
downloadaur-6f9f927e84b0db892234f5038d17f0af3b655db0.tar.gz
fix: typo in environment variable
Signed-off-by: TheOneWithTheBraid <the-one@with-the-braid.cf>
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 053012e098a9..0eeb795c1562 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,14 +32,14 @@ prepare() {
cd ${_name}
git submodule update --init --recursive
- flutter --no-version-check --suppress-analytics clean
flutter --no-version-check --suppress-analytics pub get
}
build() {
# overriding CMake flags for aarch64 in order to ensure build
# is not failing
- if [[ "$arch" == "aarch64" ]]; then
+ if [ "$(uname -m)" == "aarch64" ]; then
+ echo "Adjusting CMake flags for aarch64."
export CXXFLAGS="${CXXFLAGS/-fstack-protector-strong/ }"
export CXXFLAGS="${CXXFLAGS/-fstack-clash-protection/ }"
fi
@@ -49,7 +49,7 @@ build() {
}
package() {
- case "$arch" in
+ case "$(uname -m)" in
"x86_64")
export FLUTTER_ARCH="x64"
;;