summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcelogeek2021-01-28 15:37:36 +0100
committercelogeek2021-02-15 18:55:43 +0100
commit14df4fd821a014184be5e7438a62f67497418507 (patch)
treef1bc8c5fa80315b259b6a7190a0c295b23e017e6
downloadaur-14df4fd821a014184be5e7438a62f67497418507.tar.gz
init project
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD52
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fdd93ef857b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = fluffychat-web-git
+ pkgdesc = Chat with your friends
+ pkgver = 0.26.1.r155.g398cb46
+ pkgrel = 1
+ url = https://fluffychat.im/
+ arch = any
+ license = AGPL3
+ makedepends = clang
+ makedepends = ninja
+ makedepends = cmake
+ optdepends = pantalaimon: used for E2E encryption
+ provides = fluffychat-web
+ conflicts = fluffychat-web
+ backup = etc/webapps/fluffychat/config.json
+ source = fluffychat::git+https://gitlab.com/famedly/fluffychat.git
+ source = flutter.tar.xz::https://storage.googleapis.com/flutter_infra/releases/beta/linux/flutter_linux_1.25.0-8.3.pre-beta.tar.xz
+ sha256sums = SKIP
+ sha256sums = 83d744e8f7861e89fe6317d9e634c0a0db06e52a50bd1c129c4254e7e6e7d25c
+
+pkgname = fluffychat-web-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fc206481f195
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.gz
+*.zst
+*.xz
+pkg/
+src/
+fluffychat/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa9effd3e67e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Celogeek <arch-aur-f5d67e@celogeek.com>
+
+_pkgname=fluffychat
+pkgname=fluffychat-web-git
+pkgver=0.26.1.r155.g398cb46
+pkgrel=1
+pkgdesc="Chat with your friends"
+arch=('any')
+url="https://fluffychat.im/"
+license=('AGPL3')
+makedepends=('clang'
+ 'ninja'
+ 'cmake')
+optdepends=('pantalaimon: used for E2E encryption')
+provides=("fluffychat-web")
+conflicts=("fluffychat-web")
+source=(
+ "$_pkgname::git+https://gitlab.com/famedly/fluffychat.git"
+ "flutter.tar.xz::https://storage.googleapis.com/flutter_infra/releases/beta/linux/flutter_linux_1.25.0-8.3.pre-beta.tar.xz"
+)
+sha256sums=('SKIP'
+ '83d744e8f7861e89fe6317d9e634c0a0db06e52a50bd1c129c4254e7e6e7d25c')
+backup=(
+ "etc/webapps/${_pkgname}/config.json"
+)
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$_pkgname"
+ ./scripts/prepare-web.sh
+}
+
+build() {
+ export PATH="${srcdir}/flutter/bin:$PATH"
+ cd "$_pkgname"
+ ./scripts/build-web.sh
+}
+
+package() {
+ cd "$_pkgname"
+
+ install -dm755 ${pkgdir}/usr/share/webapps
+ mv build/web ${pkgdir}/usr/share/webapps/${_pkgname}
+ install -Dm644 config.sample.json ${pkgdir}/etc/webapps/${_pkgname}/config.json
+ ln -s /etc/webapps/${_pkgname}/config.json ${pkgdir}/usr/share/webapps/${_pkgname}
+}
+
+# vim: set sw=2 ts=2 et: