summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPier Luigi Fiorini2017-05-07 04:57:21 +0200
committerPier Luigi Fiorini2017-05-07 04:57:21 +0200
commita01484ac23ba288dbb878cdb8d1182a508b82923 (patch)
tree56cfef9da0fdf58065a9b2c0f85846192802a8d2
parentb2d5ba0d8dbbc28d3a919178e2c277b1442c053d (diff)
downloadaur-a01484ac23ba288dbb878cdb8d1182a508b82923.tar.gz
Build with Qbs
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD20
2 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc560fbad176..19be93bb8f32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Apr 25 23:52:42 UTC 2017
+# Sun May 7 02:57:19 UTC 2017
pkgbase = fluid-git
pkgdesc = Components for Qt Quick applications with Material Design and Universal
- pkgver = 20170426.6b1dd8c
+ pkgver = 20170507.2d371a7
pkgrel = 1
url = https://liri.io
arch = i686
@@ -12,6 +12,7 @@ pkgbase = fluid-git
groups = liri-git
license = MPL2
makedepends = git
+ makedepends = qbs
makedepends = qt5-tools
depends = qt5-quickcontrols2
depends = qt5-graphicaleffects
diff --git a/PKGBUILD b/PKGBUILD
index 905d8f7449a1..fe2fb0e938a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Pier Luigi Fiorini <pierluigi.fiorini@gmail.com>
pkgname=fluid-git
-pkgver=20170426.6b1dd8c
+pkgver=20170507.2d371a7
pkgrel=1
pkgdesc="Components for Qt Quick applications with Material Design and Universal"
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url='https://liri.io'
license=('MPL2')
depends=('qt5-quickcontrols2' 'qt5-graphicaleffects' 'qt5-svg')
-makedepends=('git' 'qt5-tools')
+makedepends=('git' 'qbs' 'qt5-tools')
conflicts=('fluid')
replaces=('fluid')
provides=('fluid')
@@ -26,17 +26,19 @@ pkgver() {
}
prepare() {
- mkdir -p build
- pushd ${_gitname} && git submodule update --init && popd
+ cd ${srcdir}/${_gitname}
+ git submodule update --init
}
build() {
- cd build
- qmake LIRI_INSTALL_PREFIX=/usr CONFIG+=use_qt_paths ../${_gitname}/fluid.pro
- make
+ cd ${srcdir}/${_gitname}
+ qbs setup-toolchains --type gcc /usr/bin/g++ gcc
+ qbs setup-qt /usr/bin/qmake-qt5 qt5
+ qbs config profiles.qt5.baseProfile gcc
+ qbs build --no-install -d build profile:qt5 qbs.installRoot:/usr lirideployment.qmlDir:lib/qt/qml
}
package() {
- cd build
- make INSTALL_ROOT="${pkgdir}" install
+ cd ${srcdir}/${_gitname}
+ qbs install -d build --no-build -v --install-root $pkgdir/usr profile:qt5
}