summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2017-06-03 11:06:37 +0200
committerCarsten Teibes2017-06-03 11:06:37 +0200
commitcd4474eb79e7210a9ef4b5cc12bb22df3d95e8da (patch)
treecdd55f47a82a088a54b35dc091b613be3a038ed8
downloadaur-cd4474eb79e7210a9ef4b5cc12bb22df3d95e8da.tar.gz
[add] fluidlite-git
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..332bdd27e02c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = fluidlite-git
+ pkgdesc = A real-time software synthesizer with SF3 support (development version)
+ pkgver = r42.7b5f279
+ pkgrel = 1
+ url = https://github.com/divideconcept/FluidLite
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ makedepends = cmake
+ depends = libvorbis
+ conflicts = fluidsynth
+ source = fluidlite::git+https://github.com/divideconcept/FluidLite.git
+ md5sums = SKIP
+
+pkgname = fluidlite-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec5c7b5590e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+
+pkgname=fluidlite-git
+pkgver=r42.7b5f279
+pkgrel=1
+pkgdesc="A real-time software synthesizer with SF3 support (development version)"
+arch=('i686' 'x86_64')
+url="https://github.com/divideconcept/FluidLite"
+license=('LGPL')
+depends=('libvorbis')
+makedepends=('git' 'cmake')
+conflicts=('fluidsynth')
+source=(${pkgname%-*}::"git+https://github.com/divideconcept/FluidLite.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-*}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ rm -rf build
+ mkdir build
+}
+
+build() {
+ cd build
+ cmake ../${pkgname%-*} -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DFLUIDLITE_BUILD_STATIC=false
+ make
+}
+
+package() {
+ make -C build DESTDIR="$pkgdir/" install
+}