summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThe one with the braid2024-03-26 09:14:44 +0100
committerThe one with the braid2024-03-26 09:14:44 +0100
commit1549333060941a683c53c7c4a7dfdf1fb3ac7067 (patch)
treed25344bbf04e23ea913e52791da054027b8e1ae9
parenta8e72211fa46971b1fc971aa4cc6c704c1603000 (diff)
downloadaur-1549333060941a683c53c7c4a7dfdf1fb3ac7067.tar.gz
fix: add unzip to makedepends
Signed-off-by: The one with the braid <info@braid.business>
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD3
2 files changed, 4 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2a179969540..954d776090cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = flutter
pkgdesc = A new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android.
pkgver = 3.19.4
- pkgrel = 8
+ pkgrel = 9
url = https://flutter.dev
install = flutter.install
arch = x86_64
@@ -12,6 +12,7 @@ pkgbase = flutter
makedepends = dart>=3.3.2
makedepends = jq
makedepends = gradle
+ makedepends = unzip
noextract = material_fonts.zip
noextract = android-x86.zip
noextract = android-x64.zip
diff --git a/PKGBUILD b/PKGBUILD
index 831643866591..04b4f84726ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ _flutterarch=$(uname -m | sed s/aarch64/arm64/ | sed s/x86_64/x64/)
# this host is blocked in China, according to Flutter docs, the FLUTTER_STORAGE_BASE_URL environment variable
# should be used to provide an alternative mirror
_storagebase="${FLUTTER_STORAGE_BASE_URL:-"https://storage.googleapis.com"}"
-pkgrel=8
+pkgrel=9
pkgdesc="A new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android."
_pkgdesc="Flutter SDK component"
arch=("x86_64" "aarch64")
@@ -22,6 +22,7 @@ makedepends=(
"dart>=${_dartver}"
"jq"
"gradle"
+ "unzip"
)
options=("!emptydirs")
install="${pkgbase}.install"