summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThe one with the braid2023-10-11 18:29:20 +0200
committerThe one with the braid2023-10-11 18:29:20 +0200
commit56a5f3a1f597299cfc6b5234c9b9c97920ceec83 (patch)
treea51a40d8937529e86e4442b47cffc28e17dfa4a1
parent5493a7e704f68dd9348fbc44251834f8caea8235 (diff)
downloadaur-56a5f3a1f597299cfc6b5234c9b9c97920ceec83.tar.gz
fix: gradle permissions
Signed-off-by: The one with the braid <info@braid.business>
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 26aacac23603..6227d97e297b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -66,7 +66,7 @@ package() {
# those files *must* be read-write for end-users; not my fault *grumble*
chmod a+rw "${pkgdir}/opt/${pkgname}" "${pkgdir}/opt/${pkgname}/.pub-preload-cache"
- chmod -R a+rw "${pkgdir}/opt/${pkgname}/version" "${pkgdir}/opt/${pkgname}/bin/cache" "${pkgdir}/opt/${pkgname}/.git" "${pkgdir}/opt/${pkgname}/packags/flutter_tools/gradle"
+ chmod -R a+rw "${pkgdir}/opt/${pkgname}/version" "${pkgdir}/opt/${pkgname}/bin/cache" "${pkgdir}/opt/${pkgname}/.git" "${pkgdir}/opt/${pkgname}/packages/flutter_tools/gradle"
find "${pkgdir}/opt/${pkgname}" -name "pubspec.lock" -exec chmod a+rw {} +
find "${pkgdir}/opt/${pkgname}" -name "package_config.json" -exec chmod a+rw {} +