summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThe one with the braid2024-03-25 12:41:20 +0100
committerThe one with the braid2024-03-25 12:41:20 +0100
commit736fb22d2f0ec8e5ac5143f3d70a5fc9321ef790 (patch)
tree6c773c243f61d8acb51489d13324a8dd1d13be97
parentc4389a06a84f184ede25141a951e47c894991e56 (diff)
downloadaur-736fb22d2f0ec8e5ac5143f3d70a5fc9321ef790.tar.gz
fix: make package compatible with IDE plugins
Signed-off-by: The one with the braid <info@braid.business>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fefa9b727ded..357561784da8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = flutter
pkgdesc = A new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android.
pkgver = 3.19.4
- pkgrel = 4
+ pkgrel = 5
url = https://flutter.dev
install = flutter.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 31a28f4be0bd..90ae82dfcf0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ _flutterarch=$(uname -m | sed s/aarch64/arm64/ | sed s/x86_64/x64/)
# this host is blocked in China, according to Flutter docs, the FLUTTER_STORAGE_BASE_URL environment variable
# should be used to provide an alternative mirror
_storagebase="${FLUTTER_STORAGE_BASE_URL:-"https://storage.googleapis.com"}"
-pkgrel=4
+pkgrel=5
pkgdesc="A new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android."
arch=("x86_64" "aarch64")
url="https://${pkgname}.dev"
@@ -301,5 +301,10 @@ package() {
install -dm755 "${pkgdir}/usr/lib/${pkgname}"
install -dm755 "${pkgdir}/usr/bin"
cp -ra "${srcdir}/${pkgname}" "${pkgdir}/usr/lib"
- install -Dm755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/bin/flutter"
+ install -Dm755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/lib/${pkgname}/bin/flutter"
+ ln -sf "/usr/lib/flutter/bin/flutter" "${pkgdir}/usr/bin/flutter"
+ ln -sf "${DART_ROOT:-"/opt/dart-sdk"}/bin/dart" "${pkgdir}/usr/lib/flutter/bin/dart"
+
+ # * not my fault grumble * : The IntelliJ Flutter plugin enforces this relative Dart SDK
+ ln -sf "${DART_ROOT:-"/opt/dart-sdk"}" "${pkgdir}/usr/lib/flutter/bin/cache/dart-sdk"
}