summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrealgagu2018-03-31 15:22:46 -0500
committerfrealgagu2018-03-31 15:22:46 -0500
commit91010844787d9f05ab907a43079a0cb41ae4d122 (patch)
tree108059102521e76007eeb062912ab7c2049e5082
parent47be669f32236603e4f121f446f5545a448d9d50 (diff)
downloadaur-91010844787d9f05ab907a43079a0cb41ae4d122.tar.gz
Fixing dependencies
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
-rw-r--r--flutter.install6
4 files changed, 51 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6949cf03796..e132accecab9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,30 @@
pkgbase = flutter
- pkgdesc = Flutter is a new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android.
+ pkgdesc = A new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android.
pkgver = beta
- pkgrel = 2
+ pkgrel = 3
url = https://flutter.io
- arch = any
- license = https://github.com/flutter/flutter/blob/master/LICENSE
- depends = android-sdk
+ install = flutter.install
+ arch = x86_64
+ license = custom:https://github.com/flutter/flutter/blob/master/LICENSE
+ makedepends = git
+ makedepends = python
+ depends = glu
+ depends = java-environment
+ depends = lib32-libglvnd
+ optdepends = android-sdk
optdepends = android-studio
+ optdepends = bash
+ optdepends = dart
+ optdepends = git
optdepends = intellij-idea-community-edition
optdepends = intellij-idea-ultimate-edition
+ optdepends = perl
+ optdepends = python
+ optdepends = sh
source = flutter::git+https://github.com/flutter/flutter#branch=beta
- source = flutter.install
source = flutter.sh
source = flutter.csh
sha256sums = SKIP
- sha256sums = b8eb8c1a38e961984fe7d26fc83a86f6aa1b362c4187a1fef55ce5cbc68a8d84
sha256sums = 1dea1952d386c43948b9970382c2da5b65b7870684b8ad2ad89124e873aa485a
sha256sums = 7ef10d753cfaac52d243549764a793f44f8284a1f4b11715ccd2fa915b026a6f
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a1cc4689302b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+flutter-*.pkg.tar.xz
+flutter/
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index 272be279ae48..465f90f4f7be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,28 @@
pkgname=flutter
pkgver=beta
-pkgrel=2
-pkgdesc="Flutter is a new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android."
-arch=("any")
+pkgrel=3
+pkgdesc="A new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android."
+arch=("x86_64")
url="https://${pkgname}.io"
-license=("https://github.com/${pkgname}/${pkgname}/blob/master/LICENSE")
-depends=("android-sdk")
-optdepends=("android-studio" "intellij-idea-community-edition" "intellij-idea-ultimate-edition")
+license=("custom:https://github.com/${pkgname}/${pkgname}/blob/master/LICENSE")
+depends=("glu" "java-environment" "lib32-libglvnd")
+optdepends=("android-sdk"
+ "android-studio"
+ "bash"
+ "dart"
+ "git"
+ "intellij-idea-community-edition"
+ "intellij-idea-ultimate-edition"
+ "perl"
+ "python"
+ "sh")
+makedepends=("git" "python")
+install="${pkgname}.install"
source=("${pkgname}::git+https://github.com/${pkgname}/${pkgname}#branch=${pkgver}"
- "${pkgname}.install"
"${pkgname}.sh"
"${pkgname}.csh")
sha256sums=("SKIP"
- "b8eb8c1a38e961984fe7d26fc83a86f6aa1b362c4187a1fef55ce5cbc68a8d84"
"1dea1952d386c43948b9970382c2da5b65b7870684b8ad2ad89124e873aa485a"
"7ef10d753cfaac52d243549764a793f44f8284a1f4b11715ccd2fa915b026a6f")
@@ -25,9 +34,15 @@ build() {
}
package() {
- install -Dm755 "${pkgname}.sh" "${pkgdir}/etc/profile.d/${pkgname}.sh"
- install -Dm755 "${pkgname}.csh" "${pkgdir}/etc/profile.d/${pkgname}.csh"
+ install -Dm644 "${srcdir}/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm755 "${srcdir}/${pkgname}.sh" "${pkgdir}/etc/profile.d/${pkgname}.sh"
+ install -Dm755 "${srcdir}/${pkgname}.csh" "${pkgdir}/etc/profile.d/${pkgname}.csh"
install -d "${pkgdir}/opt/${pkgname}/"
cp -ra "${srcdir}/${pkgname}" "${pkgdir}/opt/"
chown -R "${USER}":users "${pkgdir}/opt/${pgkname}"
+ chmod a+r -R "${pkgdir}/opt/${pkgname}/bin/cache/dart-sdk/bin"
+ chmod a+x "${pkgdir}/opt/${pkgname}/bin/cache/dart-sdk/bin"
+ chmod a+x "${pkgdir}/opt/${pkgname}/bin/cache/dart-sdk/bin/snapshots"
+ chmod a+x "${pkgdir}/opt/${pkgname}/bin/cache/dart-sdk/bin/snapshots/resources"
+ chmod a+x "${pkgdir}/opt/${pkgname}/bin/cache/dart-sdk/bin/snapshots/resources/dartdoc"
}
diff --git a/flutter.install b/flutter.install
index 1367a5ce48d2..534006b51e8b 100644
--- a/flutter.install
+++ b/flutter.install
@@ -1,3 +1,7 @@
post_install() {
- echo 'You need to source /etc/profile or relogin to add flutter to your path.'
+ echo "You need to source /etc/profile or relogin to add flutter to your path."
+}
+
+post_upgrade() {
+ post_install
}