summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThe one with the braid2024-03-27 08:29:15 +0100
committerThe one with the braid2024-03-27 08:29:15 +0100
commitb47014f6f3c09e6c44b30d607cf249f32a1e568c (patch)
tree78c3360086a0682931d7882b63bec8b939e36d5d
parent6afcaf305865ef5e16e40bee3d58fccdebeb0866 (diff)
downloadaur-b47014f6f3c09e6c44b30d607cf249f32a1e568c.tar.gz
fix: provide metapackage flutter-full to provide the group
Signed-off-by: The one with the braid <info@braid.business>
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD8
2 files changed, 16 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0bc98dd1896..4e0ece5f3b45 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -34,6 +34,15 @@ pkgbase = flutter
sha256sums = 04531ee1732c18c933b5b28f5da88ed183d5aa3698b1d1e912c000928b93ec91
sha256sums = 1578e819b6ee479b6db7a095bcfa74372d3ff555642c6d6ea7112e97bb6f2027
+pkgname = flutter-full
+ pkgdesc = Flutter SDK component - full installation of development tool and runtime
+ depends = flutter-devel=3.19.4
+ depends = flutter-target-linux=3.19.4
+ depends = flutter-target-android=3.19.4
+ depends = flutter-target-web=3.19.4
+ depends = flutter-intellij-patch=3.19.4
+ provides = flutter
+
pkgname = flutter-common
pkgdesc = Flutter SDK component - common SDK files and pub cache
diff --git a/PKGBUILD b/PKGBUILD
index a15fcc634614..5d29074daedf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -104,6 +104,12 @@ build() {
find "$PUB_CACHE" -name '*.aot' -delete
}
+_package-full() {
+ pkgdesc="${_pkgdesc} - full installation of development tool and runtime"
+ depends=("${pkgbase}-devel=${pkgver}" "${pkgbase}-target-linux=${pkgver}" "${pkgbase}-target-android=${pkgver}" "${pkgbase}-target-web=${pkgver}" "${pkgbase}-intellij-patch"=${pkgver})
+ provides=("${_group}")
+}
+
_package-common() {
pkgdesc="${_pkgdesc} - common SDK files and pub cache"
@@ -261,7 +267,7 @@ _package-intellij-patch() {
ln -sf "${DART_ROOT:-"/opt/dart-sdk"}" "${pkgdir}/usr/lib/${_group}/bin/cache/dart-sdk"
}
-pkgname=("${_group}-common" "${_group}-gradle" "${_group}-tool" "${_group}-devel" "${_group}-target-linux" "${_group}-target-android" "${_group}-target-web" "${_group}-intellij-patch")
+pkgname=("${_group}-full" "${_group}-common" "${_group}-gradle" "${_group}-tool" "${_group}-devel" "${_group}-target-linux" "${_group}-target-android" "${_group}-target-web" "${_group}-intellij-patch")
for _p in "${pkgname[@]}"; do
eval "package_$_p() {