summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKppqju772022-09-06 08:29:29 +0200
committerKppqju772022-09-06 08:29:29 +0200
commit4e4416cc85c206e72246f59b81bcd866a3f2a3f3 (patch)
treef0004f4291b810b5d8e5ce1d27753a304f09a2ef
parent3ecf83094b7f81230a4afc4de3409afe389e5a6e (diff)
downloadaur-4e4416cc85c206e72246f59b81bcd866a3f2a3f3.tar.gz
Add ninja as optdepends to build linux app
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 675a62abdc5d..45d0c9574996 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = flutter-beta
pkgdesc = A new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android.
pkgver = 3.3.0_0.5.pre
- pkgrel = 1
+ pkgrel = 2
url = https://flutter.io
install = flutter.install
arch = x86_64
@@ -23,6 +23,7 @@ pkgbase = flutter-beta
optdepends = python
optdepends = android-sdk-cmdline-tools-latest: for android checks
optdepends = cmake: for linux desktop build
+ optdepends = ninja: for linux desktop build
provides = flutter=3.3.0_0.5.pre
conflicts = flutter
options = !emptydirs
diff --git a/PKGBUILD b/PKGBUILD
index a0f3b86b8871..7e038c4798eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=flutter-beta
pkgver=3.3.0_0.5.pre
-pkgrel=1
+pkgrel=2
pkgdesc="A new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android."
arch=("x86_64")
url="https://${pkgname%-beta}.io"
license=("custom" "BSD" "CCPL")
depends=("git" "glu" "java-environment" "libglvnd" "unzip")
-optdepends=("android-sdk" "android-studio" "dart" "intellij-idea-community-edition" "intellij-idea-ultimate-edition" "perl" "python" "android-sdk-cmdline-tools-latest: for android checks" "cmake: for linux desktop build")
+optdepends=("android-sdk" "android-studio" "dart" "intellij-idea-community-edition" "intellij-idea-ultimate-edition" "perl" "python" "android-sdk-cmdline-tools-latest: for android checks" "cmake: for linux desktop build" "ninja: for linux desktop build")
makedepends=("python")
provides=("${pkgname%-beta}=${pkgver}")
conflicts=("${pkgname%-beta}")