summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortiziodcaio2022-11-28 12:39:22 -0300
committertiziodcaio2022-11-28 12:39:22 -0300
commit102552109ddeeba045e12ae93824747ffe585fb9 (patch)
tree78426cc310de261599056dcfc8f205cdb5d4e5cd
downloadaur-102552109ddeeba045e12ae93824747ffe585fb9.tar.gz
Initial Commit
-rw-r--r--.SRCINFO38
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD53
-rw-r--r--dart.sh0
-rw-r--r--flutter-light.install40
-rw-r--r--flutter.csh2
-rw-r--r--flutter.sh2
7 files changed, 141 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56526040728a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+pkgbase = flutter-light
+ pkgdesc = A new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android.
+ pkgver = 3.3.8
+ pkgrel = 1
+ url = https://flutter.dev
+ install = flutter-light.install
+ arch = x86_64
+ arch = aarch64
+ license = custom
+ license = BSD
+ license = CCPL
+ makedepends = python
+ depends = git
+ depends = glu
+ depends = java-environment
+ depends = libglvnd
+ depends = unzip
+ depends = dart
+ optdepends = android-sdk
+ optdepends = android-studio
+ optdepends = intellij-idea-community-edition
+ optdepends = intellij-idea-ultimate-edition
+ optdepends = ninja
+ optdepends = perl
+ optdepends = python
+ provides = flutter
+ conflicts = flutter
+ options = !emptydirs
+ backup = opt/flutter/packages/flutter_test/pubspec.yaml
+ backup = opt/flutter/packages/flutter/pubspec.yaml
+ source = flutter-3.3.8.tar.xz::https://storage.googleapis.com/flutter_infra_release/releases/stable/linux/flutter_linux_3.3.8-stable.tar.xz
+ source = flutter.sh
+ source = flutter.csh
+ sha256sums = 407fb5d05e9ad17604bc17ad8808b8e527f2ed64dd559d62f1538ee09b92236e
+ sha256sums = 1dea1952d386c43948b9970382c2da5b65b7870684b8ad2ad89124e873aa485a
+ sha256sums = 7ef10d753cfaac52d243549764a793f44f8284a1f4b11715ccd2fa915b026a6f
+
+pkgname = flutter-light
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0be8abaac2f8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+flutter-*.pkg.tar.zst
+flutter-*.tar.xz
+flutter-*.log
+PKGBUILD-namcap.log
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a36aa4954d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Mantainer: Daniele Basso <d dot bass05 at proton dot me>
+# Contributor: Fredy GarcĂ­a <frealgagu at gmail dot com>
+# Contributor: Philip Goto <philip.goto@gmail.com>, WithTheBraid <the-one@with-the-braid.cf>
+
+pkgname=flutter-light
+_pkgname=flutter
+provides=(flutter)
+conflicts=(flutter)
+pkgver=3.3.8
+pkgrel=1
+pkgdesc="A new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android."
+arch=("x86_64" "aarch64")
+url="https://${_pkgname}.dev"
+license=("custom" "BSD" "CCPL")
+depends=("git" "glu" "java-environment" "libglvnd" "unzip" "dart")
+optdepends=("android-sdk" "android-studio" "intellij-idea-community-edition" "intellij-idea-ultimate-edition" "ninja" "perl" "python")
+makedepends=("python")
+backup=("opt/${_pkgname}/packages/${_pkgname}_test/pubspec.yaml" "opt/${_pkgname}/packages/${_pkgname}/pubspec.yaml")
+options=("!emptydirs")
+install="${pkgname}.install"
+source=(
+ "${_pkgname}-${pkgver}.tar.xz::https://storage.googleapis.com/flutter_infra_release/releases/stable/linux/${_pkgname}_linux_${pkgver/.hotfix/+hotfix}-stable.tar.xz"
+ "${_pkgname}.sh"
+ "${_pkgname}.csh"
+)
+
+sha256sums=('407fb5d05e9ad17604bc17ad8808b8e527f2ed64dd559d62f1538ee09b92236e'
+ '1dea1952d386c43948b9970382c2da5b65b7870684b8ad2ad89124e873aa485a'
+ '7ef10d753cfaac52d243549764a793f44f8284a1f4b11715ccd2fa915b026a6f')
+
+build() {
+ rm -rf "${srcdir}/${_pkgname}/bin/cache/" "${srcdir}/${_pkgname}/.pub-cache"
+ sed -i "s/\$FLUTTER_ROOT\/bin\/cache\/dart-sdk/\/opt\/dart-sdk/g" "${srcdir}/${_pkgname}/bin/internal/shared.sh"
+ sed -i "/\"\$FLUTTER_ROOT\/bin\/internal\/update_dart_sdk.sh\"/d" "${srcdir}/${_pkgname}/bin/internal/shared.sh"
+ mkdir "${srcdir}/${_pkgname}/bin/cache/"
+ ln -sf "/opt/dart-sdk" "${srcdir}/${_pkgname}/bin/cache/dart-sdk"
+ cp "${srcdir}/${_pkgname}//bin/internal/engine.version" "${srcdir}/${_pkgname}/bin/cache/engine.stamp"
+ "${srcdir}/${_pkgname}/bin/flutter" precache
+}
+
+package() {
+ install -Dm644 "${srcdir}/${_pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -Dm755 "${srcdir}/${_pkgname}.sh" "${pkgdir}/etc/profile.d/${_pkgname}.sh"
+ install -Dm755 "${srcdir}/${_pkgname}.csh" "${pkgdir}/etc/profile.d/${_pkgname}.csh"
+ install -dm755 "${pkgdir}/opt/${_pkgname}"
+ install -dm755 "${pkgdir}/usr/bin"
+ cp -ra "${srcdir}/${_pkgname}" "${pkgdir}/opt/"
+ find "${pkgdir}/opt/${_pkgname}" -type d -exec chmod a+rx {} +
+ find "${pkgdir}/opt/${_pkgname}" -type f -exec chmod a+r {} +
+ # those files *must* be read-write for end-users; not my fault *grumble*
+ chmod a+rw "${pkgdir}/opt/${_pkgname}/version" "${pkgdir}/opt/${_pkgname}/bin/cache/lockfile" "${pkgdir}/opt/${_pkgname}/bin/cache/usbmuxd.stamp" "${pkgdir}/opt/${_pkgname}/bin/cache/libimobiledevice.stamp"
+ ln -s "/opt/${pkgname}/bin/${_pkgname}" "${pkgdir}/usr/bin/"
+}
diff --git a/dart.sh b/dart.sh
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/dart.sh
diff --git a/flutter-light.install b/flutter-light.install
new file mode 100644
index 000000000000..6f7c7f3d18d5
--- /dev/null
+++ b/flutter-light.install
@@ -0,0 +1,40 @@
+post_install() {
+ groupadd -f flutterusers
+ chgrp -R flutterusers /opt/flutter
+ chmod -R g+w /opt/flutter
+ tput setaf 0 2>/dev/null
+ if [[ "$?" == "0" ]]; then
+ tput sgr0
+ printf "$(tput setaf 4)Flutter was installed on $(tput setaf 2)/opt/flutter$(tput sgr0)\n"
+ printf "$(tput setaf 4)$(tput sgr0)\n"
+ printf "$(tput setaf 4)In case you encounter problems using Flutter as regular user, add your user into the group flutterusers:$(tput sgr0)\n"
+ printf "$(tput setaf 2)gpasswd -a \${USER} flutterusers$(tput sgr0)\n"
+ printf "$(tput setaf 4)$(tput sgr0)\n"
+ printf "$(tput setaf 4)Re-login your terminal in to the group flutterusers:$(tput sgr0)\n"
+ printf "$(tput setaf 2)newgrp flutterusers$(tput sgr0)\n"
+ printf "$(tput setaf 4)$(tput sgr0)\n"
+ printf "$(tput setaf 4)Run the following command to see if there are any dependencies you need to install to complete the setup (for verbose output, add the -v flag):$(tput sgr0)\n"
+ printf "$(tput setaf 2)flutter doctor$(tput sgr0)\n"
+ else
+ printf "Flutter was installed on /opt/flutter\n"
+ printf "\n"
+ printf "In case you encounter problems using Flutter as regular user, add your user into the group flutterusers:\n"
+ printf "gpasswd -a \${USER} flutterusers\n"
+ printf "\n"
+ printf "Re-login your terminal in to the group flutterusers:\n"
+ printf "newgrp flutterusers\n"
+ printf "\n"
+ printf "Run the following command to see if there are any dependencies you need to install to complete the setup (for verbose output, add the -v flag):\n"
+ printf "flutter doctor\n"
+ fi
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ groupdel flutterusers
+ printf "$(tput setaf 4)If you had added/modified files or permissions in folder /opt/flutter is possible you need to delete it manually.$(tput sgr0)\n"
+ printf "$(tput setaf 2)rm -rf /opt/flutter$(tput sgr0)\n"
+}
diff --git a/flutter.csh b/flutter.csh
new file mode 100644
index 000000000000..fdb197131b7d
--- /dev/null
+++ b/flutter.csh
@@ -0,0 +1,2 @@
+setenv FLUTTER_HOME /opt/flutter
+setenv PATH ${PATH}:${FLUTTER_HOME}/bin:
diff --git a/flutter.sh b/flutter.sh
new file mode 100644
index 000000000000..5b3db4b8b9be
--- /dev/null
+++ b/flutter.sh
@@ -0,0 +1,2 @@
+export FLUTTER_HOME=/opt/flutter
+export PATH=${PATH}:${FLUTTER_HOME}/bin