summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfluxcdbot2020-12-03 10:23:28 +0000
committerfluxcdbot2020-12-03 10:23:28 +0000
commita3fcb593e4024fcf41828ddc795b7590fc115112 (patch)
tree0fb11fa81c94fc1eddd2336253026fdb60cbf869
downloadaur-a3fcb593e4024fcf41828ddc795b7590fc115112.tar.gz
Updated to version v0.4.2 release 1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..08e807baa021
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = flux-go
+ pkgdesc = Open and extensible continuous delivery solution for Kubernetes
+ pkgver = 0.4.2
+ pkgrel = 1
+ url = https://fluxcd.io/
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = APACHE
+ makedepends = go
+ depends = glibc
+ optdepends = kubectl
+ provides = flux-bin
+ conflicts = flux-bin
+ replaces = flux-cli
+ source = flux-go-0.4.2.tar.gz::https://github.com/fluxcd/flux2/archive/v0.4.2.tar.gz
+
+pkgname = flux-go
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0489b25bd29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Aurel Canciu <aurelcanciu@gmail.com>
+# Maintainer: Hidde Beydals <hello@hidde.co>
+
+pkgname=flux-go
+pkgver=0.4.2
+pkgrel=1
+pkgdesc="Open and extensible continuous delivery solution for Kubernetes"
+url="https://fluxcd.io/"
+arch=("x86_64" "armv6h" "armv7h" "aarch64")
+license=("APACHE")
+provides=("flux-bin")
+conflicts=("flux-bin")
+replaces=("flux-cli")
+depends=("glibc")
+makedepends=("go")
+optdepends=("kubectl")
+source=(
+ "$pkgname-$pkgver.tar.gz::https://github.com/fluxcd/flux2/archive/v$pkgver.tar.gz"
+)
+sha512sums=(
+ e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
+)
+
+build() {
+ cd "flux2-$pkgver"
+ export CGO_LDFLAGS="$LDFLAGS"
+ export CGO_CFLAGS="$CFLAGS"
+ export CGO_CXXFLAGS="$CXXFLAGS"
+ export CGO_CPPFLAGS="$CPPFLAGS"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -ldflags "-X main.VERSION=$pkgver" -o flux-bin ./cmd/flux
+}
+
+check() {
+ cd "flux2-$pkgver"
+ make test
+}
+
+package() {
+ cd "flux2-$pkgver"
+ install -Dm755 flux-bin "$pkgdir/usr/bin/flux"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}