summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 05:28:17 -0600
committerBrian Bidulock2015-06-10 05:28:17 -0600
commit285cbea4c7d3e49f779e25eabe9c13ec9934914c (patch)
treedc03e7ba745d848a4db9b190e79efb9b25b383af
downloadaur-285cbea4c7d3e49f779e25eabe9c13ec9934914c.tar.gz
initial version
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD42
-rw-r--r--fluxbox-git.desktop30
3 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b0e0908604ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = fluxbox-git
+ pkgdesc = Lightweight stacking WM with tabbing, dockapps, etc.
+ pkgver = 1.3.7.16.g69d1333
+ pkgrel = 2
+ url = http://www.fluxbox.org/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = fribidi
+ depends = imlib2
+ depends = libxft
+ depends = libxinerama
+ depends = libxpm
+ depends = libxrandr
+ optdepends = xorg-xmessage: for using the fbsetbg and fluxbox-generate_menu utilities
+ provides = fluxbox=1.3.7.16.g69d1333
+ conflicts = fluxbox
+ options = !libtool
+ source = fluxbox-git::git://git.fluxbox.org/fluxbox.git
+ source = fluxbox-git.desktop
+ md5sums = SKIP
+ md5sums = c3cf99bfa58862724e0061e3881679aa
+
+pkgname = fluxbox-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e52b83c82d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Limao Luo <luolimao+AUR@gmail.com>
+# Contributor: Devin Cofer <ranguvar@archlinux.us>
+# Contributor: Cainã Costa <sryche@archlinux-br.org>
+# Contributor: Patrick Bartels <p4ddy.b@gmail.com>
+
+pkgname=fluxbox-git
+pkgdesc="Lightweight stacking WM with tabbing, dockapps, etc."
+pkgver=1.3.7.16.g69d1333
+pkgrel=2
+arch=(i686 x86_64)
+url=http://www.fluxbox.org/
+license=(MIT)
+depends=(fribidi imlib2 libxft libxinerama libxpm libxrandr)
+makedepends=(git)
+optdepends=('xorg-xmessage: for using the fbsetbg and fluxbox-generate_menu utilities')
+provides=(${pkgname%-*}=$pkgver)
+conflicts=(${pkgname%-*})
+options=(!libtool)
+source=($pkgname::git://git.fluxbox.org/${pkgname%-*}.git
+ $pkgname.desktop)
+md5sums=('SKIP'
+ 'c3cf99bfa58862724e0061e3881679aa')
+
+pkgver() {
+ cd $pkgname/
+ git describe --tags --long | sed 's|Release-||;s|[_-]|.|g'
+}
+
+build() {
+ cd $pkgname/
+ autoreconf -fi
+ ./configure --prefix=/usr --enable-xft --enable-xinerama --enable-imlib2 --enable-nls
+ make
+}
+
+package() {
+ cd $pkgname/
+ make DESTDIR="$pkgdir" install
+ install -Dm644 ../$pkgname.desktop "$pkgdir"/usr/share/xsessions/${pkgname%-*}.desktop
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
diff --git a/fluxbox-git.desktop b/fluxbox-git.desktop
new file mode 100644
index 000000000000..f9ff287172c7
--- /dev/null
+++ b/fluxbox-git.desktop
@@ -0,0 +1,30 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=XSession
+Name=Fluxbox
+Icon=fluxbox
+Exec=startfluxbox
+TryExec=fluxbox
+GenericName=Window Manager
+GenericName[fr]=Gestionnaire de Fenêtres
+GenericName[pt]=Gestor de Janelas
+Comment=Highly configurable and low resource X11 Window manager
+Categories=WindowManager;Application;System
+StartupNotify=false
+NoDisplay=true
+X-GNOME-WMName=fluxbox
+X-GNOME-Autostart-Phase=WindowManager
+X-GNOME-Provides=windowmanager
+X-GNOME-Autostart-Notify=false
+Actions=XDE;
+
+[Desktop Action XDE]
+Name=XDE
+Icon=xde
+Exec=xde-session -desktop FLUXBOX -startwm fluxbox
+Comment=Fluxbox in an XDE session
+
+[Window Manager]
+SessionManaged=true
+StartupNotification=false
+X-XDE-Managed=false