summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralive4ever2016-06-26 15:02:04 +0700
committeralive4ever2016-06-26 15:02:04 +0700
commitb52c2467e155b5b15f76e81f03f3cc7b0ce769f9 (patch)
treec763f70fac0d689f4339258b4248062c671bf7c5
downloadaur-b52c2467e155b5b15f76e81f03f3cc7b0ce769f9.tar.gz
Initial commit
Found an interesting fluxbox theme on box-looks.org. I don't want to put something inside /usr directory without pacman being unable to index the file. So that, I create a PKGBUILD. Feel free to use this fluxbox style to add some 'traffic light' look on your fluxbox window.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..47530e10b45a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = fluxbox-theme-ciremai
+ pkgdesc = Simple fluxbox theme based on OSX Yosemite look
+ pkgver = 20160422
+ pkgrel = 1
+ url = https://www.box-look.org/p/1016926/
+ arch = any
+ license = GPL
+ depends = fluxbox
+ source = 173825-Ciremai.tar.gz::https://dl.opendesktop.org/api/files/download?id=1461767798
+ sha256sums = 7d5b86f9333ec760a5d80f020c8cb5040d7fc4a29287537d3e908be31da0f11f
+
+pkgname = fluxbox-theme-ciremai
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a561c0502fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: alive4ever <alive4ever at live dot com>
+pkgname=fluxbox-theme-ciremai
+pkgver=20160422
+pkgrel=1
+pkgdesc="Simple fluxbox theme based on OSX Yosemite look"
+arch=('any')
+url="https://www.box-look.org/p/1016926/"
+license=('GPL')
+depends=('fluxbox')
+source=("173825-Ciremai.tar.gz::https://dl.opendesktop.org/api/files/download?id=1461767798")
+sha256sums=('7d5b86f9333ec760a5d80f020c8cb5040d7fc4a29287537d3e908be31da0f11f')
+
+build() {
+ cd "$srcdir"
+ printf "Extracting Ciremai themes to srcdir\n"
+ bsdtar -xf $srcdir/Ciremai.tar.gz
+}
+
+package() {
+ printf "Installing Ciremai theme to pkgdir\n"
+ mkdir -p $pkgdir/usr/share/fluxbox/styles/Ciremai/pixmaps
+ cd $srcdir/Ciremai
+ install -m644 theme.cfg $pkgdir/usr/share/fluxbox/styles/Ciremai
+ cd $srcdir/Ciremai/pixmaps
+ for a in * ;
+ do install -m644 $srcdir/Ciremai/pixmaps/"$a" \
+ $pkgdir/usr/share/fluxbox/styles/Ciremai/pixmaps/"$a" ;
+ done
+ printf "Installation finished.\n"
+}