summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2016-10-27 23:01:18 +0200
committerPiotr Rogoża2016-10-27 23:01:18 +0200
commit3247d07d2e1f36af47874a77afa7137668f7f1b3 (patch)
tree30ea81a523e9b577b95580960d67496d89b82423
parent9925caf6c29c73ef8435d61a3584018851f4cdc7 (diff)
downloadaur-3247d07d2e1f36af47874a77afa7137668f7f1b3.tar.gz
Fixed pkgver function
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd82173d38f8..a5b3beaccc94 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Oct 7 18:56:05 UTC 2016
+# Thu Oct 27 21:01:03 UTC 2016
pkgbase = xflux-gui-git
pkgdesc = Better lighting for Linux. Open source GUI for xflux
- pkgver = 0b562044
- pkgrel = 3
+ pkgver = r187.0b56204
+ pkgrel = 1
url = https://justgetflux.com/linux.html
arch = any
license = MIT
@@ -15,7 +15,7 @@ pkgbase = xflux-gui-git
depends = libindicator-gtk2
depends = libappindicator-gtk2
depends = python2-xdg
- provides = xflux-gui
+ provides = xflux-gui=r187.0b56204
conflicts = xflux-gui
source = git://github.com/xflux-gui/xflux-gui.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d534614ad3b3..0015c4875ea2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: dracorp aka Piotr Rogoza <piotr dot r dot public at gmail dot com>
pkgname=xflux-gui-git
-pkgver=0b562044
-pkgrel=3
+pkgver=r187.0b56204
+pkgrel=1
pkgdesc='Better lighting for Linux. Open source GUI for xflux'
arch=(any)
url='https://justgetflux.com/linux.html'
license=(MIT)
-provides=(xflux-gui)
+provides=(xflux-gui=$pkgver)
conflicts=(xflux-gui)
depends=(
hicolor-icon-theme
@@ -19,7 +19,6 @@ libappindicator-gtk2
python2-xdg
)
makedepends=(git)
-# install='xflux-gui.install'
source=('git://github.com/xflux-gui/xflux-gui.git')
_gitname='xflux-gui'
md5sums=(SKIP)
@@ -27,7 +26,9 @@ md5sums=(SKIP)
pkgver(){
if [ -d "$srcdir"/$_gitname ]; then
cd "$srcdir"/$_gitname
- git describe --always | sed 's|-|.|g'
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" )
fi
}
package(){