summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2016-08-30 22:47:39 +0200
committerPiotr Rogoża2016-08-30 23:05:33 +0200
commit967401cfac4a39e80b8ab1851981819084dcf585 (patch)
tree628a0fba2ea485360109328d1d2595e93caa82dc
downloadaur-967401cfac4a39e80b8ab1851981819084dcf585.tar.gz
Initial commit. Added new package.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
-rw-r--r--xflux-gui.install12
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..73d190597126
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Tue Aug 30 21:05:21 UTC 2016
+pkgbase = xflux-gui-git
+ pkgdesc = Better lighting for Linux. Open source GUI for xflux
+ pkgver = 4125e70b
+ pkgrel = 1
+ url = https://justgetflux.com/linux.html
+ install = xflux-gui.install
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python2-pexpect
+ depends = xflux
+ depends = hicolor-icon-theme
+ provides = xflux-gui
+ conflicts = xflux-gui
+ source = git://github.com/xflux-gui/xflux-gui.git
+ md5sums = SKIP
+
+pkgname = xflux-gui-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05fee69ff1e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: dracorp aka Piotr Rogoza <piotr dot r dot public at gmail dot com>
+
+pkgname=xflux-gui-git
+pkgver=4125e70b
+pkgrel=1
+pkgdesc='Better lighting for Linux. Open source GUI for xflux'
+arch=(any)
+url='https://justgetflux.com/linux.html'
+license=(MIT)
+provides=(xflux-gui)
+conflicts=(xflux-gui)
+depends=(
+python2-pexpect
+xflux
+hicolor-icon-theme
+)
+makedepends=(git)
+install='xflux-gui.install'
+source=('git://github.com/xflux-gui/xflux-gui.git')
+_gitname='xflux-gui'
+md5sums=(SKIP)
+
+pkgver(){
+ if [ -d "$srcdir"/$_gitname ]; then
+ cd "$srcdir"/$_gitname
+ git describe --always | sed 's|-|.|g'
+ fi
+}
+package(){
+ cd "$srcdir/$_gitname"
+ python2 setup.py install --root="$pkgdir"
+ install -Dm755 LICENSE $pkgdir/usr/share/licenses/xflux-gui-git/LICENSE
+}
diff --git a/xflux-gui.install b/xflux-gui.install
new file mode 100644
index 000000000000..4efdbdf0250d
--- /dev/null
+++ b/xflux-gui.install
@@ -0,0 +1,12 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}