summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-07-08 23:56:04 -0600
committerBrian Bidulock2015-07-08 23:56:04 -0600
commit1c22a35e95045d26e0721ad5f2f4312fb14bf6e9 (patch)
treeba5c4c208d85dbf9be91922588a41093ea70f71b
downloadaur-1c22a35e95045d26e0721ad5f2f4312fb14bf6e9.tar.gz
initial version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
-rw-r--r--flwm-tc-FL_INTERNALS.patch66
3 files changed, 110 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5bb6863056f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = flwm-tc
+ pkgdesc = Fast Light Window Manager (an enhanced version by the Tiny Core team)
+ pkgver = 1.14
+ pkgrel = 2
+ url = http://flwm.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = fltk
+ source = ftp://distro.ibiblio.org/pub/linux/distributions/tinycorelinux/4.x/x86/release/src/flwm-1.14.tgz
+ source = flwm-tc-FL_INTERNALS.patch
+ md5sums = 95db0e6f37ff04c7d070f02cc3d42799
+ md5sums = 9a54bf10ff1028e7a32b1a730d7de76d
+
+pkgname = flwm-tc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a039e9084258
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Yi Dai <plmday_at_gmail_dot_com>
+
+pkgname=flwm-tc
+pkgver=1.14
+pkgrel=2
+pkgdesc="Fast Light Window Manager (an enhanced version by the Tiny Core team)"
+arch=('i686' 'x86_64')
+url="http://flwm.sourceforge.net/"
+license=('GPL')
+depends=('fltk')
+source=(ftp://distro.ibiblio.org/pub/linux/distributions/tinycorelinux/4.x/x86/release/src/flwm-${pkgver}.tgz
+ ${pkgname}-FL_INTERNALS.patch)
+md5sums=('95db0e6f37ff04c7d070f02cc3d42799'
+ '9a54bf10ff1028e7a32b1a730d7de76d')
+
+build() {
+ cd "${srcdir}/flwm-${pkgver}"
+ patch -uNp1 < ${startdir}/${pkgname}-FL_INTERNALS.patch
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/flwm-${pkgver}"
+ install -Dm755 flwm "${pkgdir}/usr/bin/flwm"
+ install -Dm644 flwm.1 "${pkgdir}/usr/share/man/man1/flwm.1"
+}
+
diff --git a/flwm-tc-FL_INTERNALS.patch b/flwm-tc-FL_INTERNALS.patch
new file mode 100644
index 000000000000..da9d0c5cdb94
--- /dev/null
+++ b/flwm-tc-FL_INTERNALS.patch
@@ -0,0 +1,66 @@
+diff -Naur flwm-1.14/Frame.C flwm-1.14-2/Frame.C
+--- flwm-1.14/Frame.C 2012-01-06 19:30:31.000000000 +0100
++++ flwm-1.14-2/Frame.C 2012-02-18 13:44:18.221491337 +0100
+@@ -2,6 +2,9 @@
+ // Some modifications by Michael A. Losh, tagged "ML" below,
+ // Last update: 2009-09-27
+
++#ifndef FL_INTERNALS
++#define FL_INTERNALS
++
+ #include "config.h"
+ #include "Frame.H"
+ #include "Desktop.H"
+@@ -11,6 +14,7 @@
+ #include <FL/fl_draw.H>
+ #include "Rotated.H"
+
++#endif
+
+ static Atom wm_state = 0;
+ static Atom wm_change_state;
+diff -Naur flwm-1.14/main.C flwm-1.14-2/main.C
+--- flwm-1.14/main.C 2012-01-06 16:40:15.000000000 +0100
++++ flwm-1.14-2/main.C 2012-02-18 13:46:02.974257177 +0100
+@@ -2,6 +2,9 @@
+ // you can test the window controls.
+ //#define TEST 1
+
++#ifndef FL_INTERNALS
++#define FL_INTERNALS
++
+ #include "Frame.H"
+ #include <X11/Xproto.h>
+ #include <stdio.h>
+@@ -16,6 +19,9 @@
+
+ //ML
+ #include <FL/fl_ask.H>
++
++#endif
++
+ #include <signal.h>
+
+ ////////////////////////////////////////////////////////////////
+diff -Naur flwm-1.14/Rotated.C flwm-1.14-2/Rotated.C
+--- flwm-1.14/Rotated.C 2005-09-19 06:29:11.000000000 +0200
++++ flwm-1.14-2/Rotated.C 2012-02-18 13:45:50.564324407 +0100
+@@ -26,12 +26,18 @@
+
+ /* ********************************************************************** */
+
++#ifndef FL_INTERNALS
++#define FL_INTERNALS
++
+ #include <FL/x.H>
+ #if FL_MAJOR_VERSION < 2
+ # define XWindow Window
+ #endif
+ #include <FL/fl_draw.H>
+ #include "Rotated.H"
++
++#endif
++
+ #include <stdlib.h>
+ #include <string.h>
+ #include <stdio.h>