summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-07-04 12:44:53 -0700
committerxiota2023-07-04 12:44:53 -0700
commit11b61fb017db91accfd77205e355cbd8ece64776 (patch)
tree36edf3e5c5812f7ef10338e142c17fe9d78c6315
parent70708df615f18a05d466d6a32ede2184b204e856 (diff)
downloadaur-11b61fb017db91accfd77205e355cbd8ece64776.tar.gz
add missing include
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 332cbbd7bc0f..ce6957573305 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = flycast
pkgdesc = A multi-platform Sega Dreamcast, Naomi and Atomiswave emulator
pkgver = 2.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/flyinghead/flycast
arch = x86_64
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index eb753c52dd6a..ab962d4744ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@ _pkgname=flycast
pkgname="$_pkgname"
pkgver=2.1
_tag="V$pkgver"
-pkgrel=1
+pkgrel=2
pkgdesc='A multi-platform Sega Dreamcast, Naomi and Atomiswave emulator'
arch=('x86_64' 'i686')
url="https://github.com/flyinghead/flycast"
@@ -62,6 +62,12 @@ prepare() {
git submodule set-url ${submodule} "${srcdir}/${submodule##*/}"
git -c protocol.file.allow=always submodule update ${submodule}
done
+
+ # add missing include
+ _file='core/deps/breakpad/src/client/linux/handler/minidump_descriptor.h'
+ if ! grep cstdint "$_file" > /dev/null ; then
+ sed -Ei 's@^(#include "common/using_std_string.h")$@\1\n#include <cstdint>@' "$_file"
+ fi
}
build() {