summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2022-12-22 09:34:33 -0800
committerxiota2022-12-22 09:34:33 -0800
commit536af148b22b340dce2fa8c53f076b79858eab08 (patch)
treea71e5fc0affef9433d8e9c9fa0ca526d6717e6e8
downloadaur-536af148b22b340dce2fa8c53f076b79858eab08.tar.gz
flycast 2.0: Initial commit
-rw-r--r--.SRCINFO31
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD49
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c93715105434
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = flycast
+ pkgdesc = A multi-platform Sega Dreamcast, Naomi and Atomiswave emulator
+ pkgver = 2.0
+ pkgrel = 1
+ url = https://github.com/flyinghead/flycast
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ makedepends = python
+ makedepends = systemd
+ depends = libgl
+ depends = libzip
+ depends = zlib
+ depends = alsa-lib
+ provides = flycast
+ provides = reicast
+ conflicts = flycast
+ source = flycast::git+https://github.com/flyinghead/flycast.git#tag=v2.0
+ source = SDL::git+https://github.com/libsdl-org/SDL
+ source = libchdr::git+https://github.com/rtissera/libchdr
+ source = luabridge::git+https://github.com/vinniefalco/LuaBridge
+ source = breakpad::git+https://github.com/flyinghead/mingw-breakpad
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = flycast
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..077cba5fa488
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+_pkgname=flycast
+pkgname="$_pkgname"
+pkgver=2.0
+pkgrel=1
+pkgdesc='A multi-platform Sega Dreamcast, Naomi and Atomiswave emulator'
+arch=('x86_64' 'i686')
+url="https://github.com/flyinghead/flycast"
+license=('GPL2')
+depends=('libgl' 'libzip' 'zlib' 'alsa-lib')
+makedepends=('git' 'cmake' 'python' 'systemd')
+provides=("$_pkgname" reicast)
+conflicts=("$_pkgname")
+source=(
+ "$_pkgname"::"git+$url.git#tag=v$pkgver"
+ "SDL"::"git+https://github.com/libsdl-org/SDL"
+ "libchdr"::"git+https://github.com/rtissera/libchdr"
+ "luabridge"::"git+https://github.com/vinniefalco/LuaBridge"
+ "breakpad"::"git+https://github.com/flyinghead/mingw-breakpad"
+)
+md5sums=(
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+)
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+
+ # git submodule update --init --recursive
+ for submodule in core/deps/{SDL,libchdr,luabridge,breakpad}; do
+ git submodule init ${submodule}
+ git submodule set-url ${submodule} "${srcdir}/${submodule##*/}"
+ git -c protocol.file.allow=always submodule update ${submodule}
+ done
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ cmake -B build -S "$srcdir/$_pkgname" \
+ -DCMAKE_INSTALL_PREFIX='/usr'
+ make -C build
+}
+
+package() {
+ cd "$srcdir/$_pkgname/build"
+ make DESTDIR="${pkgdir}" install
+}