summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaura Demkowicz-Duffy2022-02-16 19:30:54 +0000
committerLaura Demkowicz-Duffy2022-02-16 19:30:54 +0000
commitb93c277136577142d61e3563972c8eb352575184 (patch)
tree10f30b22e51666b968cb89fb0e267039e6f63694
downloadaur-b93c277136577142d61e3563972c8eb352575184.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..40d1d9786c92
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = flyingcarpet-cli
+ pkgdesc = Wireless, encrypted file transfer over automatically configured ad hoc networking
+ pkgver = 4.1
+ pkgrel = 1
+ url = https://github.com/spieglt/FlyingCarpet
+ arch = x86_64
+ license = BSD
+ noextract = flyingCarpetLinuxCLI
+ source = https://github.com/spieglt/FlyingCarpet/releases/download/v4.1/flyingCarpetLinuxCLI
+ md5sums = 7433b0a5ae2fb405791b4532c7bee178
+
+pkgname = flyingcarpet-cli
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0521773081d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Laura Demkowicz-Duffy <laura@demkowiczduffy.co.uk>
+pkgname=flyingcarpet-cli
+pkgver=4.1
+pkgrel=1
+pkgdesc="Wireless, encrypted file transfer over automatically configured ad hoc networking"
+arch=(x86_64)
+url="https://github.com/spieglt/FlyingCarpet"
+license=('BSD')
+source=("$url/releases/download/v$pkgver/flyingCarpetLinuxCLI")
+noextract=("flyingCarpetLinuxCLI")
+md5sums=('7433b0a5ae2fb405791b4532c7bee178')
+
+package() {
+ install -Dm 0755 $srcdir/flyingCarpetLinuxCLI $pkgdir/usr/bin/$pkgname
+}