summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam2022-01-20 16:02:31 +0100
committerSam2022-01-20 16:02:31 +0100
commit55d90a795aa42127f387f24353a2cf14ae1b825e (patch)
tree9f8a41d877e5d8d93c28bbbcf6142a4657c7c4bc
downloadaur-55d90a795aa42127f387f24353a2cf14ae1b825e.tar.gz
initial files. fm v0.12.1
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD17
3 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2c8172ad9cbf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = fm-bin
+ pkgdesc = A terminal based file manager
+ pkgver = 0.12.1
+ pkgrel = 1
+ url = https://github.com/knipferrc/fm
+ arch = x86_64
+ license = MIT
+ provides = fm
+ conflicts = fm
+ source_x86_64 = https://github.com/knipferrc/fm/releases/download/v0.12.1/fm_0.12.1_linux_amd64.tar.gz
+ sha256sums_x86_64 = 8e97f4cda0e90774a41222390cbccf61cae73b57dae8d72004c7038f76e164a4
+
+pkgname = fm-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a806fb02e27c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar*
+*pkg*
+src \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..558fd1da23cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Sam Peters <dev at libertycloud dot de>
+pkgname=fm-bin
+pkgver=0.12.1
+pkgrel=1
+pkgdesc="A terminal based file manager"
+arch=('x86_64')
+url="https://github.com/knipferrc/${pkgname%-bin}"
+license=('MIT')
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+source_x86_64=("$url/releases/download/v$pkgver/${pkgname%-bin}_${pkgver}_linux_amd64.tar.gz")
+sha256sums_x86_64=('8e97f4cda0e90774a41222390cbccf61cae73b57dae8d72004c7038f76e164a4')
+
+package() {
+ install -Dm755 "${pkgname%-bin}" "$pkgdir/usr/bin/${pkgname%-bin}"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/${pkgname%-bin}/LICENSE"
+}