summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Herrmann2017-05-09 14:01:35 +0200
committerMichael Herrmann2017-05-09 14:01:35 +0200
commit9ab706867f7938818d4366a0a973ff51cae74512 (patch)
treeaa986963df21f6be09555740f76155505a45dc80
parent403bbdbf14a2b2f0842c4466c3f724111e770765 (diff)
downloadaur-9ab706867f7938818d4366a0a973ff51cae74512.tar.gz
Changes for fman 0.4.3
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
-rw-r--r--fman.install28
3 files changed, 48 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26dc8fd1c28f..c4ccf9525c55 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
-# Generated by mksrcinfo v8
-# Fri Apr 14 10:23:59 UTC 2017
pkgbase = fman
pkgdesc = A modern file manager for power users. Beautiful, fast and extensible
- pkgver = 0.4.1
+ pkgver = 0.4.3
pkgrel = 1
- url = https://fman.io/
- arch = i686
+ url = https://fman.io
+ install = fman.install
arch = x86_64
license = custom
- source = https://www.dropbox.com/s/21somfqm8n1bfoz/fman-0.4.1.deb
- sha256sums = b3224c1e69206587b974a93692a44b700c704984ce481c73057eb3733141fa8b
+ depends = qt5-base
+ depends = openssl
+ optdepends = qt5-svg
+ source = https://fman.io/updates/arch/fman-0.4.3.pkg.tar.xz
+ sha256sums = 6da21fcaf3527d2930eb26e1f36ee0fbc9abe7b5a41bc07126b7ccf609b29fc2
pkgname = fman
diff --git a/PKGBUILD b/PKGBUILD
index 49834c22e1a9..77659c41b892 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
# Maintainer: dmitry.romanov <dmitry.romanov85@gmail.com>
+# Maintainer: Michael Herrmann <michael+removethisifyouarehuman@herrmann.io>
pkgname=fman
-pkgver=0.4.1
+pkgver=0.4.3
pkgrel=1
pkgdesc="A modern file manager for power users. Beautiful, fast and extensible"
-arch=('i686' 'x86_64')
-url="https://fman.io/"
+arch=('x86_64')
+url="https://fman.io"
license=('custom')
-depends_x86_64=()
-depends_i686=()
-makedepends=()
+depends=('qt5-base' 'openssl')
+optdepends=('qt5-svg')
+install=fman.install
-source=("https://www.dropbox.com/s/21somfqm8n1bfoz/fman-0.4.1.deb")
-sha256sums=('b3224c1e69206587b974a93692a44b700c704984ce481c73057eb3733141fa8b')
+source=('https://fman.io/updates/arch/fman-0.4.3.pkg.tar.xz')
+
+sha256sums=('6da21fcaf3527d2930eb26e1f36ee0fbc9abe7b5a41bc07126b7ccf609b29fc2')
package() {
- tar -zxf data.tar.gz -C "${pkgdir}"
- chmod -R 755 "${pkgdir}"
-}
+ tar xf "${srcdir}/fman-0.4.3.pkg.tar.xz" -C "${pkgdir}"
+} \ No newline at end of file
diff --git a/fman.install b/fman.install
new file mode 100644
index 000000000000..832427d5267a
--- /dev/null
+++ b/fman.install
@@ -0,0 +1,28 @@
+post_install() {
+ :
+#!/bin/sh
+
+set -e
+
+pacman-key --add /opt/fman/public.gpg-key
+pacman-key --lsign-key B015FE599CFAF7EB
+
+if ! grep -qx "\[fman\]" /etc/pacman.conf ; then
+ echo -e '\n[fman]\nInclude = /etc/pacman.d/fman' >> /etc/pacman.conf
+fi
+}
+post_upgrade() {
+ :
+#!/bin/sh
+# When we don't specify an --after-upgrade script for fpm, --after-install is
+# called after upgrades as well (according to the fpm documentation, in order to
+# preserve backwards compatibility). We therefore have this script here - even
+# though it is currently empty - to ensure that our --after-install script
+# is not called after mere upgrades as well.
+}
+post_remove() {
+ :
+#!/bin/sh
+set -e
+perl -i~ -0777 -pe 's:\n\[fman\]\nInclude = /etc/pacman.d/fman\n::g' /etc/pacman.conf
+}