summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilkii Brewster2022-12-21 01:29:45 +0000
committerMilkii Brewster2022-12-21 01:29:45 +0000
commit3d9d61646910099b2f89b7924e827d5343a05ee0 (patch)
tree9ac97fa309878f1cf0aa272aa697bc8eccd098e7
parent0e4776c33907847f2c2d2fc29acd03d59b57fb6f (diff)
downloadaur-3d9d61646910099b2f89b7924e827d5343a05ee0.tar.gz
fix for new build
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD47
2 files changed, 19 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d3a9b2101cb..417b651935c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fmedia-git
pkgdesc = fast media player/recorder/converter
- pkgver = v1.12.1.r0.d7c611d
+ pkgver = android.v0.8.r0.12cd09b
pkgrel = 1
url = https://github.com/stsaz/fmedia
arch = x86_64
@@ -9,7 +9,6 @@ pkgbase = fmedia-git
makedepends = svn
makedepends = flac
makedepends = mpg123
- makedepends = libjpeg9
makedepends = libpulse
makedepends = unzip
makedepends = jdk8-openjdk
@@ -21,11 +20,11 @@ pkgbase = fmedia-git
provides = fmedia
conflicts = fmedia-git
conflicts = fmedia
- source = git+https://github.com/stsaz/fmedia
+ source = git+https://github.com/stsaz/ffbase
+ source = git+https://github.com/stsaz/ffaudio
source = git+https://github.com/stsaz/ffos
- source = git+https://github.com/stsaz/ff
- source = git+https://github.com/stsaz/ff-3pt
- source = git+https://github.com/gypified/libmp3lame#commit=d5ecd40
+ source = git+https://github.com/stsaz/avpack
+ source = git+https://github.com/stsaz/fmedia
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
@@ -33,4 +32,3 @@ pkgbase = fmedia-git
md5sums = SKIP
pkgname = fmedia-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 94a2e9700079..eaccc64787cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Milk Brewster <milk on freenode>
_pkgname="fmedia"
pkgname="${_pkgname}-git"
-pkgver=v1.12.1.r0.d7c611d
+pkgver=android.v0.8.r0.12cd09b
pkgrel=1
pkgdesc="fast media player/recorder/converter"
arch=("x86_64")
@@ -9,18 +9,18 @@ url="https://github.com/stsaz/fmedia"
license=('unknown')
groups=()
depends=('sqlite')
-makedepends=('git' 'svn' 'flac' 'mpg123' 'libjpeg9' 'libpulse' 'unzip' 'jdk8-openjdk' 'dos2unix' 'cmake' 'gtk3')
+makedepends=('git' 'svn' 'flac' 'mpg123' 'libpulse' 'unzip' 'jdk8-openjdk' 'dos2unix' 'cmake' 'gtk3')
provides=("${pkgname}" "fmedia")
conflicts=("${pkgname}" "fmedia")
replaces=()
backup=()
options=()
install=
-source=('git+https://github.com/stsaz/fmedia'
+source=('git+https://github.com/stsaz/ffbase'
+ 'git+https://github.com/stsaz/ffaudio'
'git+https://github.com/stsaz/ffos'
- 'git+https://github.com/stsaz/ff'
- 'git+https://github.com/stsaz/ff-3pt'
- 'git+https://github.com/gypified/libmp3lame#commit=d5ecd40'
+ 'git+https://github.com/stsaz/avpack'
+ 'git+https://github.com/stsaz/fmedia'
)
noextract=()
md5sums=('SKIP'
@@ -38,35 +38,16 @@ pkgver() {
build() {
- cd "$srcdir/ff-3pt"
+ cd "$srcdir/fmedia/alib3"
+ make
+ make md5check
+ make install
+ cd ../../
- if [ -d "/tmp/ff3pt-build" ]; then
- rm -rf /tmp/ff3pt-build
- fi
- mkdir -p _src
+ cd fmedia
+ make
+ make install
- curl -L "https://sourceforge.net/projects/lame/files/latest/download?source=files" --output "_src/lame-3.100.tar.gz"
- curl -L "https://sourceforge.net/projects/soxr/files/latest/download?source=files" --output "_src/soxr-0.1.3-Source.tar.xz"
-
- mkdir -p _bin/linux-amd64
-
- cd "$srcdir/ff-3pt"
- echo && echo && make alac
- echo && echo && make dynanorm
- echo && echo && make fdk-aac
- echo && echo && make flac
- echo && echo && make lame
- echo && echo && make mac
- echo && echo && make mpg123
- echo && echo && make musepack
- echo && echo && make ogg
- echo && echo && make opus
- echo && echo && make soxr
- echo && echo && make vorbis
- echo && echo && make wavpack
- cd "$srcdir/${_pkgname}"
- export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:../ff-3pt/_bin/linux-amd64
- make FF3PTLIB=../ff-3pt/_bin/linux-amd64 install
}
check() {