summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2016-05-14 14:04:09 +0200
committerMichel Zou2016-05-14 14:04:09 +0200
commit2f177177ed5d212031a45181a3693b6f49fe82a4 (patch)
tree67cff6f0acf80730edb20192b6f19802823cbc4b
downloadaur-2f177177ed5d212031a45181a3693b6f49fe82a4.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e854c9c3beb9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sat May 14 12:04:09 UTC 2016
+pkgbase = fmilib
+ pkgdesc = open-source implementation of the FMI open standard
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = http://www.jmodelica.org/FMILibrary
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = glibc
+ source = http://www.jmodelica.org/downloads/FMIL/FMILibrary-2.0.1-src.zip
+ sha1sums = 975b23233e8eeba39eb503a429f8d74069cbcb3d
+
+pkgname = fmilib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88f06985dc65
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+pkgname=fmilib
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="open-source implementation of the FMI open standard"
+arch=('i686' 'x86_64')
+url="http://www.jmodelica.org/FMILibrary"
+depends=('glibc')
+license=('BSD')
+source=("http://www.jmodelica.org/downloads/FMIL/FMILibrary-${pkgver}-src.zip")
+sha1sums=('975b23233e8eeba39eb503a429f8d74069cbcb3d')
+
+prepare() {
+ cd "$srcdir"/FMILibrary-${pkgver}
+
+ # do not override CMAKE_INSTALL_PREFIX
+ sed -i "/CMAKE_INSTALL_PREFIX/d" CMakeLists.txt
+
+ # install doc in /usr/share
+ sed -i "s|DESTINATION doc)|DESTINATION share/doc/fmilib)|g" CMakeLists.txt
+}
+
+build() {
+ cd "$srcdir"/FMILibrary-${pkgver}
+ mkdir -p build && cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd "$srcdir"/FMILibrary-${pkgver}/build
+ make DESTDIR="$pkgdir" install
+}