summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorphyskets2018-07-09 22:30:03 +0530
committerphyskets2018-07-09 22:30:03 +0530
commiteed4c358a5ad0a4938175aa0e60545bf6ec6bcbd (patch)
tree01c35229a621e92d22df4c01d909a352d2ea053a
downloadaur-eed4c358a5ad0a4938175aa0e60545bf6ec6bcbd.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD37
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7209d5990593
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = fmlib
+ pkgver = 1.3
+ pkgrel = 1
+ url = https://dmsmith.lmu.build/
+ arch = x86_64
+ license = MIT
+ makedepends = gcc-fortran
+ depends = libgfortran.so
+ source = FM_files_1.3.zip::https://dmsmith.lmu.build/FM1.3/FM_files.zip
+ sha256sums = 5553b8e5fcd0e875fa591df0b2dd08d92c2aa90e455d0909a391bd305334a645
+
+pkgname = fmlib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f269b841f78f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: physkets <physkets@tutanota.com>
+
+pkgname=fmlib
+pkgver=1.3
+pkgrel=1
+pkgdec="A fortan multiple-precision arithmetic library"
+arch=('x86_64')
+url="https://dmsmith.lmu.build/"
+license=('MIT')
+depends=('libgfortran.so')
+makedepends=('gcc-fortran')
+source=("FM_files_${pkgver}.zip::https://dmsmith.lmu.build/FM${pkgver}/FM_files.zip")
+sha256sums=('5553b8e5fcd0e875fa591df0b2dd08d92c2aa90e455d0909a391bd305334a645')
+
+build() {
+ cd "$srcdir/FM_files/"
+ mkdir -p build/libs
+ mkdir -p build/mods
+ gfortran -O3 -shared -fPIC -J./build/mods -o ./build/libs/libfmsave.so fmsave.f95
+ gfortran -O3 -shared -fPIC -J./build/mods -o ./build/libs/libfm.so fm.f95
+ gfortran -O3 -shared -fPIC -J./build/mods -o ./build/libs/libfmzm90.so fmzm90.f95
+}
+
+check() {
+ cd "$srcdir/FM_files/"
+ export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$srcdir/FM_files/build/libs/"
+ gfortran -O3 -I./build/mods -L./build/libs -o test.out TestFM.f95 -lfmsave -lfm -lfmzm90
+ ./test.out
+ gfortran -O3 -I./build/mods -L./build/libs -o sample.out SampleFM.f95 -lfmsave -lfm -lfmzm90
+ ./sample.out
+}
+
+package() {
+ install -Dm755 -t "$pkgdir/usr/lib" "$srcdir/FM_files/build/libs/"*.so
+ install -Dm755 -t "$pkgdir/usr/include/" "$srcdir/FM_files/build/mods/"*.mod
+ install -Dm644 "$srcdir/FM_files/LICENSE.txt" "$pkgdir/usr/share/licenses/fmlib/LICENSE.txt"
+}