summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormztikk2021-11-14 18:47:18 +0100
committermztikk2021-11-14 18:47:18 +0100
commit931a2f5e1eaa20e028a8a7f96b591460f128cc87 (patch)
tree01bd3b52b38409578792b853261259c9eaeecd8a
downloadaur-931a2f5e1eaa20e028a8a7f96b591460f128cc87.tar.gz
fmnl 0.1.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD19
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9baaeabb155a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = fmnl
+ pkgdesc = Formats newlines of input with a given string
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/mztikk/fmnl
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = MIT
+ makedepends = rust
+ makedepends = cargo
+ makedepends = git
+ provides = fmnl
+ conflicts = fmnl
+ source = fmnl::git+https://github.com/mztikk/fmnl.git#branch=master
+
+pkgname = fmnl-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6aaadadd6785
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: mztikk <mztikk@outlook.de>
+pkgbase=fmnl
+pkgname=fmnl-git
+conflicts=('fmnl')
+provides=('fmnl')
+pkgver=0.1.0
+pkgrel=1
+makedepends=('rust' 'cargo' 'git')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+pkgdesc="Formats newlines of input with a given string"
+url="https://github.com/mztikk/fmnl"
+source=('fmnl::git+https://github.com/mztikk/fmnl.git#branch=master')
+license=('MIT')
+
+package() {
+ cd $srcdir
+ cargo install --no-track --all-features --root "$pkgdir/usr/" --path ./fmnl
+}
+sha256sums=('SKIP')