summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormaz-12015-11-05 18:01:08 +0800
committermaz-12015-11-05 18:01:08 +0800
commit19c2dfedad2584baf4a96153d4e4fd20bc603613 (patch)
treebf38835ff237da55402d4634269798077d062b50
downloadaur-19c2dfedad2584baf4a96153d4e4fd20bc603613.tar.gz
init
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD42
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d10b35cc96f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = fmodex
+ pkgdesc = An advanced audio engine
+ pkgver = 4.44.33
+ pkgrel = 1
+ url = http://www.fmod.org/
+ arch = i686
+ arch = x86_64
+ license = custom
+ source = fmodapi44433linux.tar.gz::https://www.dropbox.com/s/48eipphfgf46yc1/fmodapi44433linux.tar.gz?dl=1
+ md5sums = SKIP
+
+pkgname = fmodex
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25cb4684a7c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# $Id$
+# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: Christoph Zeiler <archNOSPAM_at_moonblade.dot.org>
+
+# Note: This packae is proprietary and distribution is limited. However, we
+# have written permission to by the FMOD CEO to distribute this in binary form.
+pkgname=fmodex
+pkgver=4.44.33
+pkgrel=1
+pkgdesc="An advanced audio engine"
+arch=('i686' 'x86_64')
+url="http://www.fmod.org/"
+license=('custom')
+source=("fmodapi44433linux.tar.gz::https://www.dropbox.com/s/48eipphfgf46yc1/fmodapi44433linux.tar.gz?dl=1")
+## source=fmodapi44433linux.tar.gz?dl=1
+md5sums=('SKIP')
+
+package() {
+ cd fmodapi${pkgver//./}linux
+
+ mkdir -p ${pkgdir}/usr/lib
+ mkdir -p ${pkgdir}/usr/include/fmodex
+
+ cp -d api/lib/* ${pkgdir}/usr/lib/
+ [[ $CARCH == "i686" ]] && rm ${pkgdir}/usr/lib/*64*
+
+ if [[ $CARCH == "x86_64" ]]; then
+ cd ${pkgdir}/usr/lib
+ ln -sf libfmodex64-${pkgver}.so libfmodex-${pkgver}.so
+ ln -sf libfmodexL64-${pkgver}.so libfmodexL-${pkgver}.so
+ cd ${srcdir}/fmodapi${pkgver//./}linux
+ fi
+
+ cp api/inc/* ${pkgdir}/usr/include/fmodex/
+
+ install -Dm644 documentation/LICENSE.TXT ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+
+ mkdir -p ${pkgdir}/usr/share/doc/fmodex
+ cp -r documentation examples ${pkgdir}/usr/share/doc/fmodex
+}
+
+# vim:set ts=2 sw=2 et: