summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJor Bashllari2018-05-26 18:03:20 +0200
committerJor Bashllari2018-05-26 18:03:20 +0200
commit15ad8a9612a950fb44eb241871e8a97701cc003b (patch)
tree9be4219cc6ba4b9363add710209907380565e905
downloadaur-15ad8a9612a950fb44eb241871e8a97701cc003b.tar.gz
complete PKGBUILD
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD30
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd2d4604d592
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = fmui-git
+ pkgver = r9.78596be
+ pkgrel = 1
+ url = https://github.com/seebye/fmui
+ arch = x86_64
+ arch = i686
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ depends = toilet
+ depends = fzf
+ depends = mpc
+ depends = bash
+ depends = mpd
+ optdepends = cava
+ optdepends = vis
+ provides = fmui
+ conflicts = fmui
+ source = fmui-git::git+https://github.com/seebye/fmui.git
+ md5sums = SKIP
+
+pkgname = fmui-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b89fa308e198
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Jor Bashllari <altnate2000@gmail.com>
+pkgname=fmui-git
+_pkgname=fmui
+pkgver=r9.78596be
+pkgrel=1
+arch=( 'x86_64' 'i686' 'armv7h' 'aarch64' )
+url="https://github.com/seebye/fmui"
+license=( 'GPL3' )
+provides=($_pkgname)
+conflicts=($_pkgname)
+depends=( 'toilet' 'fzf' 'mpc' 'bash' 'mpd' )
+optdepends=( 'cava' 'vis' )
+source=("$pkgname::git+https://github.com/seebye/$_pkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ mkdir -p "${pkgdir}/usr/bin"
+ mkdir -p "${pkgdir}/usr/lib/$_pkgname"
+ install -D -m755 ./actions.sh "${pkgdir}/usr/lib/$_pkgname"
+ install -D -m755 ./info.sh "${pkgdir}/usr/lib/$_pkgname"
+ install -D -m755 ./keys.sh "${pkgdir}/usr/lib/$_pkgname"
+ install -D -m755 ./fmui "${pkgdir}/usr/lib/$_pkgname"
+ ln -s "${pkgdir}/usr/lib/$_pkgname/fmui" "${pkgdir}/usr/bin/fmui"
+}